I am attempting to create a deployment package through Visual Studio 2010

When right-clicking my project and selecting "Package" from the context menu I receive the following error:

Error 1 The Project Item "" cannot be deployed through a Feature with Farm scope.

I have tried every option available in the feature > scope drop down list and they all throw their matching error.

My project consists of a single visual web part and I have added an additional assembly to the package which points to the output of another project in my solution. I have tried removing this assembly but to no avail.

Any suggestions?

EDIT: Wes Hackett's answer did the trick for me. I had thought that I tried all possible deployment types but I've also restarted my machine so maybe that helped.

2 Answers 2


You say 'Farm' scoped feature for the feature, try changing the scope to 'Site' and calling package again.

If memory serves a vis web part normally uses a site collection scoped feature.

  • You are correct. I had thought that I tried all possible options but maybe the system restart also had some effect. My thanks for your assistance, now I just need to find out where it got deployed to :) Nov 12, 2010 at 2:31

Sounds like the Manifest XML for the package is screwed. Use the Feature designer surface to restore the manifest and ensure the merge file is blank (only has the empty tag in).

  • You answer appears to be the most logical solution given the invalid information posted in my question. I thank you for your assistance but changing the deployment type to "site" fixed my issue. Nov 12, 2010 at 2:32
  • No worries, it's usually the simple things that trip us up :)
    – James Love
    Nov 12, 2010 at 8:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.