2

I'm trying to deploy a new feature on sharepoint 2010 with scope web. The deploy seems to run successfully, but the feature is not prensent in feature manager. While visual Studio deploys the feature, it returns the message:

"{ProjectRoot}\pkg\Debug\SPTimerJobExample\SPTimerJobExample.dll -> GAC EXCEPTION: The system cannot find the file specified. (Exception from HRESULT: 0x80070002) ========== "

Here is the entire deploy output:

Build started: Project: SPTimerJobExample, Configuration: Debug Any CPU ------ c:\Windows\Microsoft.NET\Framework\v4.0.30319\Microsoft.Common.targets(1360,9): warning MSB3245: Could not resolve this reference. Could not locate the assembly "GruppoPA.Carige.Reclami.HelperAnagrafiche". Check to make sure the assembly exists on disk. If this reference is required by your code, you may get compilation errors. SPTimerJobExample -> C:\Users\Administrator\Desktop\Timerjob\SPTimerJobExample\SPTimerJobExample\bin\Debug\SPTimerJobExample.dll Successfully created package at: C:\Users\Administrator\Desktop\Timerjob\SPTimerJobExample\SPTimerJobExample\bin\Debug\TimerJobPegno.wsp ------ Deploy started: Project: SPTimerJobExample, Configuration: Debug Any CPU ------ Active Deployment Configuration: Quick Deploy (GAC/BIN Only) (CKSDev) Recycle IIS Application Pool: Skipping application pool recycle because no matching package on the server was found. Copy to GAC/BIN (CKSDev): ------ Quick Copying Binaries: SPTimerJobExample ------
{ProjectRoot}\pkg\Debug\SPTimerJobExample\SPTimerJobExample.dll -> GAC EXCEPTION: The system cannot find the file specified. (Exception from HRESULT: 0x80070002) ========== Build: 1 succeeded or up-to-date, 0 failed, 0 skipped ========== ========== Deploy: 1 succeeded, 0 failed, 0 skipped ==========

1

Looks like your file is not added to GAC (Global assembly cache). Go to your bin folder:

C:\Users\Administrator\Desktop\Timerjob\SPTimerJobExample\SPTimerJobExample\bin\Debug

and drag the file:

SPTimerJobExample.dll

to the assembly folder:

C:\Windows\assembly

Now redeploy using visual studio.

It looks like its deployed to the GAC before and is trying to find the dll file within the GAC folder but it cant find it to remove it and re-add it back into the GAC from the bin folder.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.