1

I exported a Core Search Results Web Part and created a new Visual Web Part in a Visual Studio project. I have added some code to the .cs page and the code for my exported webpart to the .webpart file of the VS project.

Everything builds fine but I can't seem to deploy this to my web application and get this error: "Error occurred in deployment step 'Activate Features': Feature with Id '1a1f1126-a013-4408-8771-b279696fbb11' is not installed in this farm, and cannot be added to this scope."

Now I have no idea what feature this is that isn't installed in the farm and how can I move past this?

I have done this entire process before on our test environment and the deployment was successful and no issues whatsoever but I can't seem to make this work on our production environment. Any ideas?

Thank you very much!!!!

2 Answers 2

1

'1a1f1126-a013-4408-8771-b279696fbb11' is not a standard Feature so I'll assume that it's your own feature. You can check that by double clicking the feature in Solution Explorer and look for "Feature Id" in the properties window (F4 if not open). I guess that some thing went wrong in the deploy part.

You write that you've created a Visual Web Part of your own. But then you've replaced the content of the .webpart file with an exported Core Search Result Web part. The result of that will be that you'll add a new configuration of the Core Search Result Web Part to the "Web Part Gallery" and not any for your new web part.

4
  • You're right, it is the id for my feature. Well what I am trying to do is create a new web part based on the Core Search Results Web Part which has a changed query, changed XSL etc. I followed this guide to make this work kjellsj.blogspot.ca/2010/08/… and the first time, on the Test environment it worked fine but now I keep getting that error....tried the options listed in the other answer but still facing same error
    – Tudor
    Jul 27, 2012 at 20:40
  • You can try the following: In VS retract the solution to make sure it's not deployed, Package the solution to make sure you have an up to date WSP. Open 'SharePoint 2010 Management Shell' run Add-SPSolution -LiteralPath '<Full path to the wsp in the bin\debug folder below your project>' and see if that gives you an error message you can use Jul 27, 2012 at 20:50
  • You are the man!!! That works, so I added the solution using the Managment Shell and then used Install-SPSolution to install it, then activated it in Site Settings->Site Collection Features and I can now insert it into the web page. This is great! Thank You Thank You! Any idea why there is a problem doing it from VS?
    – Tudor
    Jul 27, 2012 at 21:04
  • No, not if this worked, then VS should also have worked, but ... Jul 27, 2012 at 21:16
0

I've had problems with that error before, I think what fixed it for me was an IISReset, running Visual Studios in Administrator mode, and rebuilding.

Try these links: http://mbsguru.blogspot.com/2011/06/resolving-error-occurred-in-deployment.html

http://social.msdn.microsoft.com/Forums/is/sharepointdevelopment/thread/afe4560d-6705-4505-9576-0d762f25007e

3
  • hmm I gave that a try as well as the links but I can't seem to shake this error. any other ideas?
    – Tudor
    Jul 27, 2012 at 20:48
  • Check your variables, they may be uninstantiated.
    – Mike
    Jul 27, 2012 at 20:59
  • Well it looks like Per's answer in the other comment worked, I added and instlled the wsp package and it works fine. I still don't know why it doesn't work from VS....thanks for all the help!
    – Tudor
    Jul 27, 2012 at 21:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.