I have a SharePoint feature built with Visual Stuido 2010. Everything has been working on my project untill I changed the Site URL for the SharePoint project. Now when I goto deploy my solution I get the error:

The "ValidatePackage" task was not given a value for the required parameter "ProjectService".

Ok great I need to find the ValidatePackage task that is called on deploy and fix the ProjectService parameter.

Where would I go to find the ValidatePackage task? I have search in Visual Studio but no luck. I aslo tried searching in files but again nothing was found.

Update If I create a new solution. Createa blank project and select deploy I get the same error.

C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\v10.0\SharePointTools\Microsoft.VisualStudio.SharePoint.targets

Seems to have 18 warnings in it, such as:

Warning 6 The element 'ItemGroup' in namespace 'http://schemas.microsoft.com/developer/msbuild/2003' has invalid child element 'Package' in namespace 'http://schemas.microsoft.com/developer/msbuild/2003'. List of possible elements expected: 'Item, Reference, COMReference, COMFileReference, Xdcmake, Bscmake, ClCompile, ClInclude, Midl, ResourceCompile, PreLinkEvent, CustomBuildStep, Manifest, ProjectConfiguration, NativeReference, ProjectReference, Compile, EmbeddedResource, Content, Page, Resource, ApplicationDefinition, None, BaseApplicationManifest, Folder, Import, Service, WebReferences, WebReferenceUrl, FileAssociation, BootstrapperFile, PublishFile, CodeAnalysisDependentAssemblyPaths, CodeAnalysisDictionary, CodeAnalysisImport, Link, ResourceCompile, PreBuildEvent, PostBuildEvent' in namespace 'http://schemas.microsoft.com/developer/msbuild/2003'. C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\v10.0\SharePointTools\Microsoft.VisualStudio.SharePoint.targets 181 8 Miscellaneous Files


I tried repearing VS2010 and the error remains.


If I use CKSDev I can deploy OK. It is jsut the built in Visual Studio 2010 deploy that is failing. Also means that pressing f5 for debugging does not work.


I tried removing VS2010 and reinstalling but the error remained on a reinstall. I dont think the VS uninstall removes everything as it rememberd my extension details :(

  • does it work if you revert back the change (if yes, what's the url)? same environment before and after above error? Dec 19, 2011 at 14:50
  • Looks to be enviomental as resotring the files fro msource control gives the same errors.
    – John
    Dec 19, 2011 at 15:22
  • 1
    the warning you see when you open .targets file may not help you because I get similar warnings as well and my environment is working fine. Did you try moving source code to some other dev env and see if it builds? Dec 19, 2011 at 15:35
  • Glad you get the warnings as well. Don't have another enviroment that I can get my hands on at the moment. Will see what else I can work out.
    – John
    Dec 19, 2011 at 15:49

1 Answer 1


Using Visual Studio 2010 Uninstall Utility I remvoed VS2010 from my machine. I then made sure SP1 was removed as well.

I reinstalled VS2010 and then applied SP1. I then hit the deploy button on the same code as before and it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.