2

Ok. I have been getting this issue once in a while and I need to know how to fix it.

Scenario: I wanted some custom actions performed on my workflow. So created an activity library and a class that inherited the 'CodeActivity' abstract class. I even referenced that library in my workflow project and I was able to drag and drop the activity into the Workflow.

The issue starts when I try to deploy the workflow, Visual Studio 2012 tried to activate the Feature that has the Workflow related xml files and Boom.. This is the error message That I got:

Error occurred in deployment step 'Activate Features': Microsoft.Workflow.Client.ActivityNotFoundException: The activity named 'WorkflowXaml_{GUID1}' from scope '/SharePoint/default/{GUID2}/{GUID3}' was not found.
HTTP headers received from the server - ActivityId: {GUID4}. NodeId: <server name>.
Scope: /SharePoint/default/{GUID2}/{GUID3}. Client ActivityId : {GUID5}

The crazy part is the moment I remove my custom action, the Workflow deploys fine! This happened to me once before and I had to avoid creating a few variables in a specific scope to avoid the same issue. Sounds crazy enough? You Bet!

This is what I have kind of understood, The activities are getting scoped somewhere in the back-end and there is a mismatch or something.

Any suggestions? I badly need the custom activity to get deployed.

1

Well I found an alternative solution in the form of a REST WCF web service for SharePoint 2013. (Guidelines Can be found here)

After you have a working WCF web service. Use the HttpSend activity to call the method.

0

Seems like you try to use Workflow Action without deploying it. Please check out the following article it describes how to deploy custom code activity on workflow server.

  • Thanks.. Is this for VS 2012? Btw, there was a comment which said to use web services. Actually that was my plan B. Which is better in terms of efficiency? I'm sending custom emails that has HTML tags. – Muhammedh Oct 22 '14 at 16:01
  • 1
    Much simpler to create a declarative workflow that will call your web service, which you can develop and deploy as farm solution. – Roman Oct 22 '14 at 16:42
  • Hope my answer is what you had in your mind. Thanks! – Muhammedh Oct 23 '14 at 6:06
0

This error is due to limitation in number of variables per scope. The limit is 50. I fixed it by following this link: Detailed explanation here.

Found the answer through this question

0

This error in my case was because i had cast exception from guid to string. Error was not self-explanatory nor pointing to exact cause. run time exceptions in the code might also throw this same error message. Because of run time issue it did not deploy the workflow and for the same reason we see activity named ------ was not found

  • SharePoint has it's own way of displaying errors... Can take you for a ride some times :( – Muhammedh Apr 22 '15 at 5:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.