4

I am trying to build a WebPart project and I am trying to deploy the same into my SharePoint dev site which I created using the SharePoint Central Administration. But the issue which I am facing while deploying the website from Visual Studio is in the step 'Recycle Application Pool', with the below listed error message.

Error Message:

Error occurred in deployment step 'Recycle IIS Application Pool': Cannot connect to the SharePoint site: Make sure that this is a valid URL and the SharePoint site is running on the local computer. If you moved this project to a new computer or if the URL of the SharePoint site has changed since you created the project, update the Site URL property of the project.

I have tried the below listed options with no luck,

  • Permission check for the user account against the content database.
  • Run Visual studio using the administrator account.
  • Reset IIS and the corresponding website.
3

Please verify following things

  • Current logged in user is in Administrator group of SharePoint server.
  • Please try once Recycling IIS by IISRESET it worked for me in past
| improve this answer | |
  • Thanks @pholpar for taking time and correcting the link. It may be updated in last edit and somehow I skipped to verify the links. Thanks again. – Aakash Maurya Mar 15 '19 at 6:16
1

Can you check whether the site URL you see in the properties for the project reflects the binding in IIS?

| improve this answer | |
  • Yes the site URL property mentioned in the project contains the URL of the website and I am able to browse the same by entering the address in browser. – Arvind Raj Oct 14 '15 at 10:10
  • Do you have a site collection created at the root of the Web app? – Evariste Oct 14 '15 at 14:11
  • yes Evariste, first created the webapplication and on top of that had created the site collection. – Arvind Raj Oct 14 '15 at 18:37
1

It worked for me after I mapped a new workspace in the team explorer and downloaded the code again and then tried publishing the site to a new Sharepoint site.

| improve this answer | |
0

make sure that the database server is running

| improve this answer | |
  • yes all the services and applications were running – Arvind Raj May 31 '18 at 2:31
0

You have to do only two things

1) First close the solution which you are deploying.

2) Recycling IIS by IISRESET on command prompt it worked for me.

| improve this answer | |
0

Try to publish solution to *.wsp file and deploy or update solution via powershell or sp command line.

After that try to deploy it from Visual Studio.

This hint was helpful for me when i had the same situation.

| improve this answer | |
0

For me the issue was that the user deploying using visual studio did not have db_owner permission on the content database for the web application. I was able to get it working after giving the permissions.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.