0

I get this message:

Sorry, apps are turned off. If you know who runs the server, tell them to enable apps.

Please give me the steps to enable this.

  • This msdn article gives a start-to-end step-by-step for doing this. You've probably done some of it already, so just jump in where you need to. – TZHX Dec 14 '12 at 12:29
  • 2
    Do you know if there is a way to handle this without buying a domain, but just on a testing environnement? – Seb Dec 14 '12 at 13:14
  • Did you ever find a solution to your problem? I am having the same problem, and possibly because the SharePoint server instance is on a local network and there is no external domain set up for it. – user16617 Apr 25 '13 at 9:17
  • Note: that MSDN article strongly suggests you use SSL, but then doesn't show you how to do it. In fact, if you follow the steps, then some things will be configured incorrectly if you later want to setup SSL. – Mike2500 Apr 25 '14 at 21:02
2

Here is a handy Powershell script you can use for activating apps in 2013:

# Check if the execution policy is set to Unrestricted  
$policy = Get-ExecutionPolicy  
if($policy -ne "Unrestricted"){  
Set-ExecutionPolicy "Unrestricted"  
}  

# Check if current script is running under administrator credentials  
$currentPrincipal = New-Object Security.Principal.WindowsPrincipal(     [Security.Principal.WindowsIdentity]::GetCurrent() )  
if ($currentPrincipal.IsInRole( [Security.Principal.WindowsBuiltInRole]::Administrator ) -eq $false) {   
(get-host).UI.RawUI.Backgroundcolor="DarkRed"   
clear-host   
write-host "Warning: PowerShell is not running as an Administrator.`n"   
exit  
}  

# Load SharePoint powershell commands  
Add-PSSnapin "microsoft.sharepoint.powershell" -ErrorAction SilentlyContinue  
cls  

# Ensure that the spadmin and sptimer services are running  
Write-Host  
Write-Host "Ensure that the spadmin and sptimer services are running" -ForegroundColor    Yellow  
net start spadminv4  
net start sptimerv4  

# Create your isolated app domain by running the SharePoint Management Shell as an administrator and typing the following command.  
Write-Host  
Write-Host "Create your isolated app domain by running the SharePoint Management Shell as an administrator and typing the following command." -ForegroundColor Yellow  
$appdomain = Read-Host "Your App Domain Name"  
Set-SPAppDomain $appdomain  

# Ensure that the SPSubscriptionSettingsService and AppManagementServiceInstance services are running   
Write-Host  
Write-Host "Ensure that the SPSubscriptionSettingsService and  AppManagementServiceInstance services are running." -ForegroundColor Yellow  
Get-SPServiceInstance | where{$_.GetType().Name -eq "AppManagementServiceInstance" -or        $_.GetType().Name -eq "SPSubscriptionSettingsServiceInstance"} | Start-SPServiceInstance  

# Verify that the SPSubscriptionSettingsService and AppManagementServiceInstance  services are running   
Write-Host  
Write-Host "Verify that the SPSubscriptionSettingsService and     AppManagementServiceInstance services are running." -ForegroundColor Yellow  
Get-SPServiceInstance | where{$_.GetType().Name -eq "AppManagementServiceInstance" -or     $_.GetType().Name -eq "SPSubscriptionSettingsServiceInstance"}  

# Specify an account, application pool, and database settings for the  SPSubscriptionService and AppManagementServiceInstance services   
Write-Host  
Write-Host "Specify an account, application pool, and database settings for the   SPSubscriptionService and AppManagementServiceInstance services." -ForegroundColor Yellow  
$login = Read-Host "The login of a managed account"  
$account = Get-SPManagedAccount $login   
$appPoolSubSvc = New-SPServiceApplicationPool -Name SettingsServiceAppPool -Account     $account  
Write-Host "SettingsServiceAppPool created (1/6)" -ForegroundColor Green  
$appPoolAppSvc = New-SPServiceApplicationPool -Name AppServiceAppPool -Account $account  
Write-Host "AppServiceAppPool created  (2/6)" -ForegroundColor Green  
$appSubSvc = New-SPSubscriptionSettingsServiceApplication –ApplicationPool     $appPoolSubSvc –Name SettingsServiceApp –DatabaseName SettingsServiceDB   
Write-Host "SubscriptionSettingsServiceApplication created  (3/6)" -ForegroundColor   Green  
$proxySubSvc = New-SPSubscriptionSettingsServiceApplicationProxy –ServiceApplication    $appSubSvc  
Write-Host "SubscriptionSettingsServiceApplicationProxy created  (4/6)" -ForegroundColor  Green  
$appAppSvc = New-SPAppManagementServiceApplication -ApplicationPool $appPoolAppSvc -Name     AppServiceApp -DatabaseName AppServiceDB  
Write-Host "AppManagementServiceApplication created  (5/6)" -ForegroundColor Green  
$proxyAppSvc = New-SPAppManagementServiceApplicationProxy -ServiceApplication $appAppSvc  
Write-Host "AppManagementServiceApplicationProxy created  (6/6)" -ForegroundColor Green   

# Specify your tenant name   
write-host  
Write-Host "Set AppSiteSubscriptionName to 'app'" -ForegroundColor Yellow  
Set-SPAppSiteSubscriptionName -Name "app" -Confirm:$false  
Write-Host "AppSiteSubscriptionName set" -ForegroundColor Green  
0

Here is a link from TechNet really going to the dept about how you can configure SharePoint for Apps, including e.g. creating a subdomain, configuring ssl certificates and starting the correct services.

0

Were you able to turn on apps? Before you get too excited turning on Apps. Sharepoint 2013 - Apps

0

You can find step by step configuration/installation instruction at : Installing The PDF Converter for SharePoint Online App in SP2013 & SP2016

The article should provide you detailed steps. I have followed the article and it works for me.

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

  • Please don't provide the link as your answer, in future if the link breaks, then your answer is of no use. – Karthik Jaganathan May 24 '17 at 8:55
  • @ Karthik Jaganathan : Done thanks for you feedback, – Clavin Fernandes May 24 '17 at 10:16
  • @ClavinFernandes that changed nothing, your answer is still a plain link. You need to provide the answer here, which on itself can be used to solve the original problem. Links are provided as a source for the solution if there's one, and additionally can be provided for a more detailed reading. – moe May 24 '17 at 10:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.