8

I am trying to add an app at SharePoint Store but I just get errors.

I've got the following error:

"Sorry, we can't seem to connect to the SharePoint Store. Try again in a bit."

Now this error occurs "sorry this site does not support apps but you can still acquire them and add them on other sites"

and after less than 1 minute it says "An unexpected error has occurred." at the central administration and at the site. I did "Configure an environment for apps for SharePoint"

I followed this links and did what they said. http://msdn.microsoft.com/en-us/library/fp179923(v=office.15).aspx http://technet.microsoft.com/en-us/library/ee806866.aspx

I created :

  • App Catalog
  • Search Service App/Proxy -started
  • App Management Service App /App Proxy -started
  • Secure Store Service App /App Proxy -started
  • Microsoft SharePoint Foundation Subscription Settings Service Application /Proxy-started

My started services on the server are:

  • App Management Service
  • Secure Store Service
  • Search Service

Other problems are When I click Central Adm./Apps/Monitor Apps add an app it gives me "Sorry, something went wrong". I couldn't find the reason.

There is a list http://technet.microsoft.com/en-us/library/fp161232.aspx but isn't it enough to configure an environment for apps for SharePoint? I just want to add an app from Sharepoint store.

Thank you.

edited: I have Web Application on port 80. There it says "Sorry, we can't seem to connect to the SharePoint Store. Try again in a bit." At central administration, it says "An unexpected error has occurred."

  • 1
    Do you have any update for this? I am having the same problem and have found no solution after weeks of trying. – astout419 Jan 29 '15 at 20:08
  • No update. I just couldn't do that. – e.ozmen Feb 2 '15 at 12:34
0

Assuming you have installed SharePoint Foundation make sure below things are configured properly

  • Apps Management Service application is configured and App Management Service running.
  • Subscription Setting Service application is configured and its service is running.

    If you have installed SharePoint Enterprise/Standard Edition then apart from above service you will also need to configure Managed Metadata Service.

Even if after setting up all required service application Apps is not working then you can try below things.

  • Navigate to Central Admin/Manage Web Application and select the required web application. From ribbon click on Manage Feature and Activate "Apps that require accessible internet facing endpoints" Feature.

  • Perform IISReset few times.

  • Run below command using SharePoint Powershell with elevated permission.Set-SPAppStoreConfiguration -Url http://office.microsoft.com -Enable $true

  • Make sure you have direct internet connectivity on your SharePoint Server or for testing purpose bypass proxy server.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.