37

I am getting this message when I want to add a app:

Sorry, apps are turned off. If you know who runs the server, tell them to enable apps.

21

You need to setup the app domain

this is a good tut but very lengthy

http://sharepointchick.com/archive/2012/07/29/setting-up-your-app-domain-for-sharepoint-2013.aspx

also this:

In order to install an App from the App Store you must setup an isolated App Domain, this is because Apps from the store deploy to their own app domain and run under a separate process from your SharePoint sites. If your SharePoint site uses the DNS alias http://sharepoint.contoso.com you could have *.apps.contoso.com as your app domain.

http://www.sharepointalex.co.uk/index.php/2012/11/enabling-sharepoint-2013-apps/

How to: Set up an on-premises development environment for apps for SharePoint

http://msdn.microsoft.com/en-us/library/fp179923(v=office.15).aspx

another resolution to that error from technet:

1) Browse to Tenant Administration Site of the HH mode Site collection

2) Create App Catalog for Tenant by clicking on Manage App Catalog

Note – Every Tenant Admin will require a App Catalog(Make sure Self site creation is enabled in order for App Catalog to get created)

3) $Sub = Get-SPSiteSubscription http://hhmodeSite (This CMDlet will help in fetching the subscription ID of the HH mode site collection)

Set-SPAppSiteSubscriptionName -Name "Name for Subscription" -SiteSubscription $Sub

We need to run the above command in order to set the unique name for domain under which these apps will run.More details can be found under http://technet.microsoft.com/en-us/library/jj219503.aspx

http://blogs.technet.com/b/harmeetw/archive/2013/01/03/sharepoint-2013-you-receive-quot-sorry-apps-are-turned-off-if-you-know-who-runs-the-server-tell-them-to-enable-apps-quot-when-trying-to-add-apps-on-host-header-site-collection.aspx

hope it helps :)

  • This URL might also help – Amit Nov 27 '13 at 13:23
0

Well, you need to Configure an environment for apps for SharePoint (SharePoint 2013), but even if you have done that, you might get that message.
You hopefully are able to fix it by following the remarks in the Troubleshooting-section of Enabling the SharePoint App Store on-premise

“Sorry, apps are turned off. If you know who runs the server, tell them to enable apps.”
This must be a catch-all error. Of course, it’s caused by setting the option in Configure Store Settings in SharePoint Central Admin to ‘no’ for allowing users to get apps from the store. Assuming that is not the problem, the error can be very frustrating. Most likely cause is a config piece that sometimes gets set, sometimes not when creating the App Management Service.
In Central Admin go to Application Management and Manage web Applications. Highlight the web app you need to access the store on (where it is currently failing) and click Manage Features. Activate the “Apps that require accessible internet facing endpoints” feature at the top. Click ok.
Click Service Connections. Most likely, the App Management Service Application for the ‘[custom]’ connections group, is not checked. Turn it on.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.