I have created a SharePoint 2010 site that is accessible both internally and externally. I have created alternate access mappings for https://<internal_url> (Extranet) and https://<external_url> (Internet).

This setup generally works fine. However, I'm experiencing some problematic bits, with the most annoying one being the following error after file upload, when Edit Properties form should be shown:

No item exists at https://**<internal_path>**/Forms/EditForm.aspx?Mode=Upload&CheckInComment=&ID=5&RootFolder=/<path>&IsDlg=1.  It may have been deleted or renamed by another user.

Web Parts Maintenance Page: If you have permission, you can use this page to temporarily close Web Parts or remove personal settings. For more information, contact your site administrator. 
Troubleshoot issues with Microsoft SharePoint Foundation. 

Note that the upload is successful but the Edit Properties popup window shows this error (the background is still there). It's not a critical issue but I know the user base, they are not very technical and we'll be facing constant support calls and lack of confidence in the solution.

Obviously, the confirmation tries to open the site at the internal URL, which is naturally unavailable externally.

I get this error only when Web Client service is started - when it's not in the same popup I get "Internet Explorer Cannot Open the Webpage" (although the logs may show the same error)

I'm also getting the same error when creating lists and document libraries, and similar situation with datasheet view for lists - the client tries to connect to the server by the internal URL and naturally fails.

At first I thought that it's caused by the DMZ infrastructure, which uses a reverse proxy - which, I thought, translates the address to the internal URL and the rest of the site works purely because SharePoint uses relative URLs. This seems not to be the case, as we did some tracing on the proxy and it in fact translates the external address to the IP address - and it doesn't show anywhere in error messages. I don't know how definitive this is as I have no idea about the tools that sysadmins use and how reliable they are - but the admins seem pretty confident. But if that's try then it seems that SharePoint is sending the internal URL to client via some other mechanism.

Any ideas how can I make this work? Or at least what's going on?

Further, the problem presents itself for libraries that either have check-in/check-out enabled or have multiple content types - others simply don't show the popup. For some libraries on the site, however, multiple content types is a part of the requirements. A valid workaround would be a way to prevent the Edit Form popup being shown after upload to a library with multiple content types.

  • is it not possible to get the SharePoint site to handle both urls through it's own alternate access mapping?
    – Nat
    Commented Jul 5, 2012 at 3:35
  • It is possible - but I don't know hard it will to be get the admins to change the network architecture as it's an organization-wide setting, and knowing them - it's probably going to be quite hard :-) I also don't entirely rule out the possibility that it's configured like that for some good reason, so that's why I'm looking at alternative options Commented Jul 5, 2012 at 7:44
  • I think you may be better off persuing that option as that is what SharePoint is designed to do. I hate to think of what else might go wrong with the translation approach that you have not found out yet.
    – Nat
    Commented Jul 5, 2012 at 23:17
  • @Nat, looks like the cause is not DMZ translating to internal address as I initially thought - please see the revised question Commented Jul 11, 2012 at 15:05

1 Answer 1


I am pretty sure this is still a matter of getting the alternate access mappings correct. Unfortunately, I am not great shakes at this. Try reading through this blog post.

You may want to try a mapping from Internal Url http://[ip.address] to Public Url http://[Public URl].

This stackoverflow question will help determine which zone you want.

  • Thanks, the link is very relevant - but not enough reputation to vote up yet :-( Commented Jul 19, 2012 at 16:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.