0

In our sharepoint 2013 environment , we have set the maximum upload limit for a file is 50MB and its working fine. 3 days before we changed that maximum upload limit to 100MB from 50MB. However we are not able to upload file beyond 50 MB. When we try to upload 90MB file from server internally it works but it was failing through internet !!

Error Msg:

Sorry, for some reason this document couldn't upload. Try again later or contact your administrator.

From Logs:

02/02/2018 15:25:52.73 w3wp.exe (server03:0x5CB4) 0x4500 SharePoint Foundation General aix9j High SPRequest.GetFileAndFolderProperties: UserPrincipalName=satish, AppPrincipalName= ,bstrUrl=https://support.office.com/sites/soa-cop ,bstrStartUrl=SiteCollectionDocuments/D drive folder bkp.zip ,ListDocsFlags=16400 ,bThrowException=True e781469e-d72a-500a-3a69-cd5ab822fc10

02/02/2018 15:25:52.73 w3wp.exe (server03:0x5CB4) 0x4500 SharePoint Foundation General ai1wu Medium

System.IO.FileNotFoundException: The system cannot find the file specified. (Exception from HRESULT: 0x80070002), StackTrace:

02/02/2018 15:24:22.85 w3wp.exe (server03:0x5CB4) 0x80CC SharePoint Foundation Monitoring b4ly Medium Leaving Monitored Scope (Request (GET:https://support.office.com/sites/soa-cop/_layouts/15/Upload.aspx?List=%7B10289773-A0B2-425A-850D-895D34F85E4D%7D&RootFolder=&IsDlg=1)). Execution Time=358.196432786849 d181469e-e729-500a-3a69-c25d83506d60

please help

1

You have to make a couple of modifications to increase the file size, which are:

First step:

  • Change the maximum upload size on the web application level

In order to do this, you have to go to:

  1. Central Administration
  2. Application Management
  3. Manage Web Applications
  4. Select Web Application you want to modify
  5. General Settings
  6. Input the new file size limit you want and save.

Second step:

  • Modify the corresponding web.config

This file is located at C:\inetpub\wwwroot\wss\VirtualDirectories\YourWebApp

Find this line: <httpRuntime maxRequestLength="51200" requestValidationMode="2.0" />

And replace it with: <httpRuntime executionTimeout="999999" maxRequestLength="102400" requestValidationMode="2.0" />

Then restart IIS with command iisreset

Source: How to Increase the Maximum Upload Size in SharePoint 2013

If you had any other problem, please refer to this article: Issues Uploading Large Files To SharePoint

0

There could be a timeout that affects the upload when you are doing from the internet. Can you increase the timeout in the web.config and try again? The default executionTimeout value is 360 seconds or six minutes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.