I have a SharePoint 2010 site collection based on a custom Publishing site definition. I'm trying to figure out why sub-sites and pages underneath a certain site (/Foo) are never included in my search results.

There is nothing obvious configured on my /Foo site or its sub-sites that would prevent them from appearing in the search results - the Allow this site to appear in search results setting is most definitely set to Yes. The site and its sub-sites are created using a sub-site Publishing site definition which is also used for all the other sites in the site collection.

Here's a description of my Search setup and configuration in my development environment.

In the configuration of the Search service application:

Content Source

I created a new content source and included http://localhost to the collection of Start Addresses for the content source. I configured a full and incremental search crawl schedule.


I created a custom scope and added a rule of type Content Source, and set it to the content source created in the previous step.

In the configuration of the site collection:

Search Settings

I set Site Collection Search Center to Enable custom scopes and set it to the URL of the Search Center: /Search/

I also set Site Collection Search Dropdown Mode to Do not show scopes dropdown, and default to target results page

Search Scopes

In the Search Scopes configuration of the site collection, I configured the custom scope to be the Default Scope under the Search Dropdown and Advanced search groups.


Here are things I've looked into and tried while troubleshooting tis:

Tried using the out-of-the-box Local SharePoint Sites content source and defining my scope to only include content from http://localhost.

Examined the crawl logs. None of the sites under /Foo appear in the crawl logs. There are no errors in the log which would indicate that the sites and pages aren't being crawled.

Reset the index and ran a full crawl.

Created an out of the box SharePoint Publishing site and search center and used the default Local SharePoint Sites content source to search for the content. None of the sites under /Foo appear in the results.

Thoroughly stumped; would appreciate any guidance on this.

Edit - 3/37/2012 Ran stsadm -o setproperty -pn portalsuperreaderaccount -pv DOMAIN\user -url http://webappurl to make sure that the search account is also configured as the super reader account. It's a site collection administrator, and also the service account, so I don't think this makes a difference.

2 Answers 2


Is the search crawler service running as an account that should have access to the sub-site?

To rule out permission issues, you could try running the service as one of the admin accounts to see if it crawls the site as expected.

  • I will confirm tomorrow, but I'm pretty sure that in my development environment, the search account is also the system account. Thanks. Mar 27, 2012 at 2:58
  • foocode, yes, the account does have unrestricted access. The site and its subsites is inheriting permissions from its parent (the root site) Mar 27, 2012 at 12:38
  • Glad you found you solution!More often than not, search crawling omissions due to permissions issues manifest themselves in file share crawling. Particularly if the service account is one created specifically for the SharePoint farm (as is recommended).
    – Beeblebrox
    Mar 29, 2012 at 23:17

The solution to this is frustratingly simple...

At the root of the site, go to Site Actions >> Site Settings and choose Search and Offline Availability under Site Administration.

Set the page indexing behavior to “Always index all Web Parts on this site”.

Save and run a full crawl.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.