0

I'm fairly new to Sharepoint, so forgive my ignorance. I'm in the new online experience o365.

I've created a communication site as my front page and added some pages to it. I wanted to create permission groups for my users so I blew out all the other groups and created them from scratch using the advanced permissions link. I created an Employees group with all employees in a restricted security setting which indicates they are all read only, which is what I want. I've added that group to the communication site main page and now all users trying to view the site need to request access.

I'm unclear on how to do this. I've used the permissions checker and typed in the group and also individuals to see if they have access, which they do. So it's odd that all but me need to request access

1
  • Its a little unclear from the way you wrote your question what permissions you assigned the users. Did you assign the users: 'Read Only' permissions or 'Restricted Read' permissions? Also, there is a built-in group that is a catch all group named 'Everyone Except External Users' - which you can use instead of enumerating a different security group or enumerating every user and updating with new ones during employee onboarding. Feb 20 at 22:39
0

Do you see the group listed on the Site Permissions page (_layouts/15/user.aspx)? And what do you mean “restricted security setting”?

You can refer to this document for a tutorial on how to create and grant permission to SharePoint Groups: SharePoint site permissions.

If you are referring to other types of groups such as security groups, no permission or special settings are needed for the group itself, just click “Grant Permissions” button on the Site Permissions page and then add the group with View Only permission as the document introduced.

2
  • It turned out there were several permission levels I could choose when creating a group. For viewers only I added in only the least privledged one. That permission level required each person to submit request for approval. Even if auto allow was turned on. So I moved the permissions up to read and it worked. Feb 25 at 14:35
  • @mikevarela ok, thanks for sharing Feb 26 at 1:23
0

First of all, why playing with the SharePoint groups that way? You have 3 main ways to provide users with access to the site, using Owners, Members and Visitors (When you click on SharePoint). I wouldn't go in the advanced mode and create more groups the way we used to do with SharePoint server, rather I'd add people I want to an Office 365 group (or Azure security group) and then invite them to my site and provide them permissions through the Share link.

This is the better way to do it, remember when you want to use more advanced stuff in SharePoint, such as Audience Targeting, it will work only with M365 Groups or Security Groups.

Keep it simple, and feel free to add these users to other M365 groups as needed (or if you prefer, Security Groups) then add them back to your site using the Share link.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.