1

I want to sync SharePoint 2019 Site Library to local file system via OneDrive using Sync option of SP Library.

I have setup the configuration as per Microsft Article in Domain Controller.

However, after successfully executing the steps mentioned in article I tried to sync from SP Library.

Following error is encountered even though I tried to create the necessary OneDrive sync folder manually.

There is no pc/domain restriction in our OneDrive tenant admin.

Note: I have even followed following article for troubleshooting but no luck.

Any help is much appreciated!

enter image description here

0

1.It may be caused by the OneDrive folder on "C:". When trying to synchronize contents, OneDrive does not have permission to create new folder in "C:". So you could try to manually create the needed folder and the synchronization will work normally.

2.It may be caused by the device is on a different domain.

Reference: Case of the OneDrive for Business “Sorry can’t add your folder right now”

3.Re-install and re-configure the OneDrive.

0

It is possible that your folder permissions got messed up. With a little trick I was able get it right again:

  1. In SharePoint Sync an arbitrary subfolder (we will delete it later)
  2. Open it in Windows Explorer (you should now see the "orphaned" folders and the newly synced one (if not this guide will not help you))
  3. Go to the OneDrive settings and make sure that you remove them by clicking stop syncing for the broken folders
  4. Delete the "orphaned" folders from step 2 (everyting should be clean now)
  5. Go back to SharePoint and Sync the (initially broken) folders
  6. Remove the subfolder from step 1 (by clicking stop syncing + delete it in Windows Explorer)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.