2

I have mapped the SharePoint Site Library as a network drive on the same SharePoint server.

However, some files are not appearing in the File system but the same files are appearing in the SharePoint site accessed through browser using same user account (Farm account used in both cases).

Following points were tried but no luck:

  1. Tried to replicate the same in another system.
  2. Also, I tried to map and access using different accounts.
  3. Even tried opening the library with "Open with explorer" option but same issue encountered.

Note:

  1. Library does not have content approval enabled or check in/ check out issues.
  2. There are only around 38 files in library.
  3. No folders present in this library.

Basic requirement was to move the files across the site, so once the file was mapped it was really fast in performance to read the file from File System using OpenBinaryDirect method of csom code and moved it to different site.

Edit: Facing following issue with OneDrive sync in SP Library.

Added registry entries as per Article but still no luck.

enter image description here

Any help is much appreciated to fulfill above requirement.

4
  • Do all files have a checked in version? (if you are using check in/check out) Dec 20, 2020 at 16:18
  • @CallumCrowley All files are checked in. Not using check in/ check out. Dec 20, 2020 at 16:27
  • How big are the files that are missing? Dec 20, 2020 at 16:30
  • @CallumCrowley around 4 MB, files that are visible are also similar size Dec 20, 2020 at 16:31

1 Answer 1

1

Here are a few things you can check to narrow down this issue:

  1. Make sure the issued files do not contain special characters that are not supported for syncing (\, /, :, *, ?, ", <, >, | , # , %, etc.).
  2. Make sure the files do not exceed the 256-character limit on Network Folder Paths (starting with the first backslash in the path name). You can rename the files in SharePoint to a shorter one and then check again.
  3. If the issue persists, try syncing with OneDrive sync app instead.

Reference: Restrictions and limitations when you sync SharePoint libraries to your computer through OneDrive for work or school.

4
  • 1. Missing files were having underscore but the visible files were also having underscores. 2. Also, there was no character limit. It was really small file names. 3. Tried the OneDrive Sync but facing error, posted screenshot in edited post. Dec 21, 2020 at 18:00
  • @SohailShaikh Would it be accessible if you download one of the issued files from SharePoint, and then upload it manually to the network drive? As for the OneDrive sync app configuration, my experience is that it does not work if set on SharePoint server, but it works if configured on the domain controller. Dec 22, 2020 at 8:10
  • I have set up the OneDrive configuration on DC but in the last step after clicking "Sync" option from SP Library, I was prompted with Microsoft account. Post authentication it showed me "Sorry, OneDrive can't add your folder right now." Can you help me on the same? I have even created the necessary folders in local File System. Dec 24, 2020 at 9:01
  • @SohailShaikh This seems like a common issue in OneDrive. See the UserVoice post here for discussion in the Comment section: onedrive.uservoice.com/forums/262982-onedrive-archive/… There are a couple of troubleshooting methods besides creating folders manually. Hope it can do some help. Dec 25, 2020 at 7:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.