1

I am facing a problem with OOTB Sharepoint 2010 Workflow at farm level. Earlier it was working fine but all of a sudden it stopped working . It's working on my Development Environment (both the environment are on different servers). I referred previous blogs related to this issue but still found no luck.

Its a simple Workflow, with no custom logic in it.

Steps which I follow:-

  1. I created a document Library and after creating I go to versioning settings and enable the content approval to(Required content approval for submitted items) -> Yes
  2. After that "Create a version each time you edit a file in the Document library" -> Create Major and Minor Version.
  3. "Who should see draft items in this document library"-> Only users who approve items (and the author of item)
  4. Once the settings are done. I created a approval 2010 workflow and selected the options "Allow this workflow to be manually started by the authenticated users with edit item permission","Start the workflow to approve publishing a major version of an item","Enable content Approval-> Checked"
  5. After all this settings, When I upload a document and publish it to major version I get Error Occurred in Workflow status column.
  6. When I check the workflow status its showing "The workflow operation failed because the workflow lookup found no matching item ".
  7. But when I proceed the same workflow by manually starting it, its working perfectly. I also tried Implementing the Designer Workflow its also working. But only OOTB Workflows are not working.

Can anyone help me with this issue, as it will be helpful to everyone who are facing the same problem just like me.

Thanks for your time.

0

I wonder if an IIS service reset would kickstart the workflow into action again? Make sure you understand at a high level what an IIS reset involves and the possible effects of it - for instance this post helps explain it.

You've explained that the workflow has been stable up until now, therefore we should look for what could have changed it. Have any Sharepoint Cumulative Updates been installed recently? This can sometimes cause unexpected effects on things like workflows.

| improve this answer | |
  • Thanks for the response, but I've tried the IIS Reset as well, but it didn't work.Can you tell me how to check the Cumulative Sharepoint updates?And latest windows updates were on 06/01/2020 – Amey Feb 27 at 10:14
  • I'm asking how to check when was the last time the Sharepoint Update has taken place.? As What I know is to go to Central Admin--> Updates and migration--> Manage Patch Status and other way to get the configuration DB is to check in "Manage Servers in farm". – Amey Feb 27 at 12:54
  • It sounds like you're in the right place - do you see Upgrade and Migration / Upgrade Status? This shows a Last Updated date for me – Tally Feb 27 at 14:14
  • I don't see any date for me :( – Amey Feb 27 at 14:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.