0

I am missionned to go from HTTP to HTTPS on our SharePoint 2013 OnPremise farm.

This farm is made of several wfe (4 - including one for Workflows), 2 application servers and 2 sql instances. Users reach the SharePoint sites through a Proxy created mostly for Load Balancing (HaProxy).

I have installed everything (certificates, bindings, AAMs) as said in article Configure Alternate Mappings for SharePoint Server.

What is my problem :

I can reach my sites through https (by typing https://myWebApp.MyDomain.com/sites/MySite ),absolutely no issue there.

When trying to reach my site using http (http://myWebApp.MyDomain.com/sites/MySite), the redirection to https (https://myWebApp.MyDomain.com/sites/MySite/SitePages/Home.aspx) is working well.

When I try to directly access to my homepage via http - Which will be the case of all my user's bookmarks- (http://myWebApp.MyDomain.com/sites/MySite/SitePages/Home.aspx), The redirection to https does not work and the page is still in http.

Could you please help me resolve this strange case of strange behavior ? Rephrasing : Could you help me resolve this issue of partial redirection from http to https please ?

What I have done :

here are my configured AAMs :

Internal URL                     |   Zone     |  Public URL for Zone
https://MyWebApp.MyDomain.com    |   Default  |  https://MyWebApp.MyDomain.com
http://MyWebApp.MyDomain.com     |   Default  |  https://MyWebApp.MyDomain.com
https://MyWebApp                 |   Intranet |  https://MyWebApp  
http://MyWebApp                  |   Intranet |  https://MyWebApp                       

Here are my bindings on my WFE1 server,on myWebApp.MyDomain.com :

Type    |  Host Name  |  Port  |  IP Address     |  Binding Info
http    |             |  80    |                 |  
https   |             |  443   |   *             |     

The right certificate is associated to the https binding. (well, these work, because I can access my Site through typing a https URL.

Thanks a lot !!

  • 1
    Did you also set the redirection in IIS? – Damjan Tomic Feb 21 at 21:29
1
+100

The best option for you would be to set up the IIS URL Rewrite Module as explained in the article below- https://www.sharepointdiary.com/2015/02/redirect-http-to-https-in-sharepoint-2013.html

I have been using it in our Production environment and it is working just fine for me.

| improve this answer | |
  • 1
    I thought this was not mandatory, because SharePoint and AAMs assure this redirection. But because it was not complete, I tried the link you shared and it worked. Thanks ! One more question : do I have to set the IIS Rewrite rule for all my WebApps, INCLUDING workflow management site ? Thx ! – Gaelle Feb 25 at 9:48
  • Yes if you want them to get redirected then you will need to do it. If you want to do this in bulk refer to the link below - imaginet.com/2017/… . They have the safest and easiest option on how to do this quickly. – Yash Kamdar Feb 27 at 19:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.