2

I've passed from http to https using certificates, Alternate Acces Mapping AND IIS module "URL Rewrite" (using these links : Configure SSL for SP2013 and IIS URL rewrite) But since then, my Search Application has some problems.

What do I have

When on my sandbox site, I try to retrieve some documents like test.xlsx or with a title "XXX_Test" by typing "test" in the searchbar. It redirects me to "https://myWebApplication.MyDomain.com/sites/MySiteCollection/_layouts/15/osssearchresults.aspx?u=https%3A%2F%2FmyWebApplication%2MyDomain%2Ecom%2Fsites%2FMySiteCollection&k=test"

And I got no results, with the message "No items match you search. Suggestions: try with another orthographe etc".

What did I do :

Before all this, I have taken some measures to redirect from http to https. My Alternate Access Mappings are well redirected, the https works. Only the search does not.

What did i try :

  1. First, identify if search services are well:

To verify that Search Services are working and running, I did the following : go under Central Administration (which remains in http) > Application Management > Manage Service Application > Search Service Application, then I click on "Result Sources" and "Add a result Source",and then, only click on "Launch Query Builder". When on it, i simply replace {searchTerm} by "test" and hit the "test the query" button. My query returns all I the documents named test_Smtg.doc/xlsx etc... and all the documents and folders containing "test" in their title.

  1. Try something in the url : I told earlier that the searchbar sent to "https://myWebApplication.MyDomain.com/sites/MySiteCollection/_layouts/15/osssearchresults.aspx?u=https%3A%2F%2FmyWebApplication%2MyDomain%2Ecom%2Fsites%2FMySiteCollection&k=test"

here, I think the https is essential. I tried to remove the s from the url parameter. like the following: "https://myWebApplication.MyDomain.com/sites/MySiteCollection/_layouts/15/osssearchresults.aspx?u=http%3A%2F%2FmyWebApplication%2MyDomain%2Ecom%2Fsites%2FMySiteCollection&k=test"

And... I got the right results.

  1. Checking in CA :

So, I thought that maybe, my problem came from the Content Source! I go back to Central Administration to check whether my https site is taken into accounts in the Local SharePoint Sites Content source : Content Sources > Local SharePoint Sites > Start Addresses :

It is good !

----- EDIT from 15/04/2020 ----

  1. Checking Top Level Errors :

i looked in my Crawl Logs and found a Top Level Error for my webapp :

"An unrecognized HTTP response was received when attempting to crawl this item. Verify whether the item can be accessed using your browser. ( Error from SharePoint site: WebExceptionStatus: SecureChannelFailure The request was aborted: Could not create SSL/TLS secure channel.; SearchID=XXXXXXXXX)"

Really strange. Because I have a Load Balancer Proxy, I edited the hosts file on the server where the Search application is running, and added the server's IP mapped with my web app's URL. I re-ran a full-crawl.

And got another top level error :

"Access is denied. Verify that either the Default Content Access Account has access to this repository, or add a crawl rule to crawl this repository. If the repository being crawled is a SharePoint repository, verify that the account you are using has "Full Read" permissions on the SharePoint Web Application being crawled. ( SearchID = YYYYY)"

This is again a strange behavior : my Default Content Access Account (name it Acct85) has the Full Read permission on my web app. I even made it a Owner of the top of my webapp (even if there is no portal site, because we have no use of one).

I searched the internet for an answer, and not one worked. What should I do ? Do you have any idea ? I am really stuck here...

----- END EDIT from 15/04/2020 ----

So I don't know what to do to make my Search work...

What do I ask you :

Do you have any idea on how I could change the settings for my search to take into account the ssl ?

I am quite puzzled, because I have to push https on production environment very soon, and I don't know if everything is going to be ok until then..

[TL;DR] : after changing several settings (IIS Bindings, SP Alternate Access Mappings and IIS URL Rewrite) to redirect all my WebApps from http to https, my Search does not work when searching under httpS site Collections. It works on http though.

Thanks a lot for your time and patience!

1

Check your content source web application URL whether it is https or HTTP. If it is HTTP URL change it to https URL.

Go to the CA -> search service application -> content source -> check the web application URL (change from http to https) -> Run the full crawl

| improve this answer | |
  • thanks for your time. I already did this : In CA -> Search Service Application -> Content Source -> Local SharePoint Sites, I erased the myWebApplication.myDomain.com and let only the myWebApplicatio.myDomain.com. Ran a full crawl. When i run a search within https, i still have the same issue : no results. And now, if I erase the S from the URL parameter, i have no result, because I erased the http in content source. Any other idea ? – Gaelle Apr 6 at 15:06
  • Are you able to access the site from browser with https? – Habibur Rahaman Apr 7 at 4:57
  • yes, I can access the site, create/edit/delete items or documents and launch workflows. The site is working well. I am thinking of two things, tell me if it will make a difference to your opinion: 1) modify my Alternate AccessMappings (and erase every reference to http) or 2) recreate the Search entirely.Note : I do not have a Global search center for this one, but I will have one on production – Gaelle Apr 7 at 6:24
  • I think it is test server. You can clean up and reconfigure the AAM... but not needed to recreate the search service application... rather you can try after reconfiguring the AAM, do index reset of search service.. clear the config cache, restart timer service, restart iis, if needed server restart.... then finally run the full crawl – Habibur Rahaman Apr 7 at 7:47
  • I earased every http reference to my webapp in AAM. I reseted index of search service, cleared config cache and restarted timer service (these two operations were made on my whole farm), i restarted IIS of my application server where the search service is running, i did not restart this server. Full crawl and still same result... – Gaelle Apr 7 at 8:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.