0

I am using sp2013. I have an acceptation environment and a production environment. On the accept environment I have installed the certificate successfully, but on production not.

On production I got this warning when I add the https binding in IIS:

One or more intermediate certificates in the certificate chain are missing. To resolve this issue, make sure that all of the intermediate certificates are installed. For more information, see http://support.microsoft.com/kb/954755. - See more at: http://www.aip.im/2010/12/error-in-iis-when-adding-secure-binding-because-intermediate-certificate-is-missing/#sthash.a3p3ZfN8.dpuf

There is a differance between these 2 environments. Accept has 1 frontend server and 1 sql environment. Production environment has 2 frontend servers and 2 sql servers.

These are the steps I did on accept environment. I add the certificate files in a folder. I go to IIS. I started "Server Certificates". I click right above on "Import". I browse to my certificate (.pfx) file. I entered the password and selected "Personal" store.

After this I selected the site and click on "Bindings". I Add a new binding and selected "https" and selected my new created certificate.

As last I created a new Alternative Access Mapping as zone "Intranet". The "Default" zone is still "http".

When I enter the https url inside the 2 frontend servers they are working fine without certificate erros. When I enter the https url from my local machine it cannot find the site, like it not exist. Local is only the http url working.

Do I need to do something else because I have on prod 2 frontend servers? I did the steps above on both prod frontend servers.

ps. I have also some other files for the certificate:

thawtePrimaryRootCA.cer

ThawteSSLCA.cer

UPDATE:

enter image description here

Here I selected my webaplication intranet: enter image description here

Here I clicked on "Edit Public URLs":

enter image description here

Extra info: We are using loadbalancer for the 2 frontendserver in Citrix Netscaler. Maybe the issue is in Netscaler?

  • what are the your AAM settings? could you please share it...Looks like you dont have proper setting for Https in AAM – Waqas Sarwar MVP Aug 28 '14 at 18:11
  • See update for printscreens. – Ola Aug 29 '14 at 7:11
  • Ok, why you need the intranet zone for Https? did you extend the web app, if not then i would remove the intranet and edit the default zone to https. then add another internal URL with http... and make sure Certs add in both WFE. – Waqas Sarwar MVP Aug 29 '14 at 13:51
0

Sounds like the Load Balancer (Citrix Netscaler) is not handling HTTPS requests.

You need to make sure it is handling HTTP and HTTPS connections to your website URL, and redirecting the HTTP to HTTPS if possible. No need for the AAMs if the Load Balancer is already doing it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.