2

We're testing a migration from Sharepoint 2010 to 2016 (installed on WIndows Server 2012R2) and we managed to make it work and import all files from old one. We have 2 main problems:

  1. Somehow our farmadmin account it's not recognized as admin account in Central Administration and for that it cannot be used to log in (we can only login with a personal account or with any other account but use http://localhost:xxx which only brings part of functionality) - we tried every solution that could find on internet but with no luck.

  2. Our User Profile Service not updating user info -> Ex: I have a user in an Active Directory group Alpha and I move it to group Beta -> I try Incremental Synchronization (no update) -> I try Full Sync (again no update) he still can see files from old group and not the new one - only way to see changes is to do an iisreset (or wait for a few hours when something happens and it updates) -> Is this a normal behavior? Because in SP2010 changes could be seen in a matter of minutes or less.

UPDATE - I managed to make sync(second issue) work by doing THIS

$sts = Get-SPSecurityTokenServiceConfig
$sts.FormsTokenLifetime = (New-TimeSpan -minutes 2)
$sts.WindowsTokenLifetime = (New-TimeSpan -minutes 2)
$sts.LogonTokenCacheExpirationWindow = (New-TimeSpan -minutes 1)
$sts.Update()
iisreset /noforce
4

For your first issue:

Whether the Farm Admin account is added to farm administrators group in CA->Security->Manage the farm administrators group?

If so, try to troubleshoot your issue as below:

  1. Switch other farm account to check if the same issue will occur.

  2. Remove and re-add the problematical farm account in the farm administrators group.

  3. Clear SharePoint configuration cache

  4. Re-run the SharePoint 2016 configuration wizard.

  5. Run SharePoint Central Administration as administrator and check again.

  6. Go to CA site settings->Site permissions->check if the farm account have full control, and check if there is Farm Administrators group in it.

1
  • Unbelievable, we've tried, except 3, all of the above - it turns out that clear configuration cache + re-run configuration wizard did the job. We've struggling with this for a month. Thank you so much!! – sTx Dec 20 '19 at 9:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.