3

I upgraded my user profile service application from SP2010 to SP2013. I upgraded only ProfileDB and Social DB and created a new Sync DB for SP2013.

After creating user profile service,when i tried to start the "User profile synchronization service" it is showing "starting" for few mins and then falls back to Stopped.

I am running the "User Profile Synchronization service" with the Farm account. FIM service is disabled and logged on with Local system account. FIM synchronization service is logged on with farm account.

Farm account has been added to the local admin group,user profile service application's administrator group ,user profile service application's permission group.

On checking the event viewer,I see the below error message when user profile service synchronization service fails to start:

Performance counters for the FIMSynchronizationService (Forefront Identity Manager Synchronization Service) service are already in the registry, no need to reinstall. This only happens when you install the same counter twice. The second time install will generate this event.

How to fix the issue and start the "user profile synchronization service"?

  • What do you see in Application event logs regarding this? There must be something there or in ULS logs that cant hint the problem. – Muhammad Zeeshan Tahir Aug 9 '16 at 15:52
  • @muhammad zeeshan tahir application event log displays the below error: Performance counters for the FIMSynchronizationService (Forefront Identity Manager Synchronization Service) service are already in the registry, no need to reinstall. This only happens when you install the same counter twice. The second time install will generate this event. – George Aug 9 '16 at 16:15
  • Alright. Can you give me a little more details about your architecture, SharePoint CU currently installed? – Muhammad Zeeshan Tahir Aug 10 '16 at 8:24
  • @MuhammadZeeshanTahir I had SP2013 SP1 and SQL server 2014.After installing the latest CU,this issue got resolved. – George Aug 11 '16 at 10:01
4

There are more reasons regarding this issue like

  • the farm account is not added to local administrator group during starting and provisioning UPS service.
  • the User Profile Sync Service account is not a member of Farm Administrator group.
  • Forefront Identity Manager Service is not running.

and SO on...

At the following articles, I found out details reasons list and how to solve it, Hope it helps you.

1

Mine was a known bug with SP2013 SP1 and SQL server 2014.You need to install any of the CU after April 2014 to fix this issue

After installing latest CU,I was able to start the user profile synchronization service without any issue

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.