1

We’ve a major issue in our main intranet portal. It’s down with a lot of errors that were not fixed by investigating on event viewer and ULS logs.

However, I’ve restored the content database to a date before the incident, but still the same issue was happening. So I created a new web app in the same farm and attached the main content database to it, but still I’m getting some errors as shown below:

Notes:

  • The central admin is working fine, but the web app is down, and they are on the same server.

  • The original web app name (which is down) is: http://sp-l1

  • The new web app that I created and attached the db to it is: http://sp-l1:8080

Here is the error I’m getting when open the site:

Sorry, something went wrong

Unknown server tag 'dev:datetimelabel'.

Correlation ID: cef1ea9e-da03-0010-814b-70100b22910d

When I search for the ID in the ULS logs, I get the below:

https://pastebin.com/raw/UZYW5wGf

  • Do you have any custom WSP packages deployed on the farm? Try to retract wsp in central administration or via PowerShell – Raf Jun 28 '19 at 7:46
  • No, we don't have any WSPs deployed to this web app – user10479125 Jun 28 '19 at 8:12
1

This error is usually caused by lack of registered assemblies in web config. Review the webconfig files and confirm that you have all necessary assemblies registered.

To further troubleshoot I would review the Windows event logs, and use process monitor to see what issues are occurring with your IIS process.

| improve this answer | |
  • Thanks Marek for the quick response and your feedback. Could you please let me know what kind of assemblies do I need to register according to these errors. Sorry for that because I'm not an expert in SharePoint, I'm just trying to fix it as our SP admin is on emergency leave. – user10479125 Jun 28 '19 at 8:00
  • No I can't this label doesn't seems to be part of outOfTheBox, do probably have some custom solution deployed in your farm? – Marek Sarad Jun 28 '19 at 8:13
  • Using Process Monitor from sysInternals may help you identify what are you missing. – Marek Sarad Jun 28 '19 at 8:14
  • You could as well change the logging level for the ULS it may give you more information. Get-SPLogLevel #check logging lever Clear-SPLogLevel #set logging lever to default. Set-SPLogLevel -EventSeverity ie -TraceSeverity verboseex #Set max level of logging. – Marek Sarad Jun 28 '19 at 8:19
  • Get yourself as well the uls log viewer it will help to make sense of the SP ULS Logs. microsoft.com/en-us/download/details.aspx?id=44020 – Marek Sarad Jun 28 '19 at 8:20
1

I fixed it by doing the following:

  • Get the GUID of your mounted content DB from the new web app.
  • Get the GUID of your original Content DB from the new wep app.
  • Update your mounted content DB GUID in the new web application with the help of your databases team or thru the PowerShell
| improve this answer | |
0

I've analyzed your log picture and want to notice that the issue is - Exception trying get context compatibility level: System.IO.FileNotFoundException: The site http://sp-l1:80/ could not be found

I suggest you to run the following Powershell code as described here.

 $tempSite = Get-SPDeletedSite
 $tempSite.Restore()
| improve this answer | |
  • It gave me the below error. But I think this is different situation, as I detached the DB from the site sp-l1:80 and attached it to the new site sp-l1:8080 – user10479125 Jun 28 '19 at 10:18
  • You cannot call a method on a null-valued expression. At line:1 char:1 + $tempSite.Restore() + ~~~~~~~~~~~~~~~~~~~ + CategoryInfo : InvalidOperation: (:) [], RuntimeException + FullyQualifiedErrorId : InvokeMethodOnNull – user10479125 Jun 28 '19 at 10:19
  • Did you create any site collection at sp-l1:8080 before you mounted db? Try to dismount db from newly created web app. Create empty site collection, remove newly created db and mount restored db. Also try to perform Test-SPContentDatabase – Raf Jun 28 '19 at 10:53
  • I have dismount db from newly created web app. Create empty site collection, remove newly created db and mount restored db... but still getting the same error – user10479125 Jun 28 '19 at 11:27
  • So, why I can see the old web app name in the log, and why it's related to the new web app anyway. Do I need to change it someweher in the iis console or the DB itself? – user10479125 Jun 28 '19 at 11:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.