0

I am trying to create a new web application in our SP 2013 Farm and i am not successful in doing it .I had created 4 web apps before without any issue and today when i tried to create a new webapp i am getting "Request Timed out "

Also i observed that the ContentDB is getting created in the DB Instance but there are no sites that are created in IIS ,I have 4 WFE and 3 App Servers .I was not able to find much in the ULS Logs enter image description here

ULS Logs

Provisioning of the web application, SharePoint - 80, has encountered the following error: System.Threading.ThreadAbortException: Thread was being aborted. at Microsoft.SharePoint.Administration.SPWebApplication.CreateDefaultInstance(SPWebService service, Guid id, String applicationPoolId, SPProcessAccount processAccount, String iisServerComment, Boolean secureSocketsLayer, String iisHostHeader, Int32 iisPort, Boolean iisAllowAnonymous, DirectoryInfo iisRootDirectory, Uri defaultZoneUri, Boolean iisEnsureNTLM, Boolean createDatabase, String databaseServer, String databaseName, String databaseUsername, String databasePassword, SPSearchServiceInstance searchServiceInstance, Boolean autoActivateFeatures)

Application error when access /_admin/extendvs.aspx, Error=Request timed out.

Update 2

I also observed one more issue which is when I am creating the web application now it is creating the site in Central Admin Server but it's not creating the site on any of the Web front ends. Also it's still giving the Request timeout.

I already checked the Web application service and it's running on all the WFEs

  • Can you please paste the ULS log info and do you have enough storage lest in DB Server – Malin De Silva Aug 19 '14 at 15:13
  • Hi Malin ..Thanks for the comment ,Yes this is a very new environment for we have lots of storage in DB server an i am attaching the logs in the question – Anil Aug 19 '14 at 15:28
  • are you trying to create the web application from server using CA or from your PC via CA. Could you please try to use the powershell script to create the web application? – Waqas Sarwar MVP Aug 19 '14 at 16:49
  • Hi Waqas I am trying to create the web app from my PC via CA .The reason i am creating this web app is that i needed to create an empty host header web application for Apps Configuration in SP 2013 – Anil Aug 19 '14 at 16:52
3

I had the same problem couple of months ago. Do you run many web-applications in your farm? From the blogpost:

This is usually because you either have too many Web Applications in your SharePoint Server, or because your SharePoint Server is slow! As part of the Web Application creation process, SharePoint resets IIS. By Default, the application pool only allows for 90 seconds for all the connections to close before it down by force. If you got this message it’s because 90 seconds wasn’t enough and we need to increase that limit.

I found the solution here, and it worked perfectly. Go into IIS and change the property "shutdown time limit" for the central admin application pool from 90 to 300 seconds. Now try to create your new web-application.

Internet Explorer cannot display the webpage when creating new Web Application in SharePoint 2013

  • HI We have only 4 web apps and i am trying to create the 5th one .And our farm is not slow as all the other web apps are working fine .I tried the option of changing the app pool default value but i am still having the same issue .I got request time out – Anil Aug 19 '14 at 15:38
  • Did you change the default value and restarted IIS after that before trying to create a new web application? – Christoffer Aug 19 '14 at 16:03
  • Yes also i observed one more issue which is when i am creating the web application now .Its creating the site in Central Admin Server but its not creating the site in any of the Web front ends .I already checked the Web application service and its running on all the WFEs – Anil Aug 19 '14 at 18:11
  • Glad to hear you got things sorted out. :) You can mark the question as answered if you want to. – Christoffer Aug 20 '14 at 6:23
1

After changing the Central admin IIS app pool timeout ,I was seeing the site only in CA server and not in WFes .What did the trick for me is i ran the SharePoint Configuration Wizard on all the WFE and App Servers and then tried creating the web app and Voila!!!!! i was able to create the web app fine ..Thanks a lot for your comment "User19952" you pointed me in the right direction

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.