1

On my server Excel Calculation Service is "started".

I tried to create new Excel Service Application but after some time I get following error.

enter image description here

And this is how it looks like after that.

enter image description here

If I try to delete, it takes even longer time (probably a few hours) and then show same request time out message.

From logs, I found two entries but none give any clue as to what the issue is.

System.Web.HttpException: Request timed out.

AND

SPTimerJobAsyncResult '9e0cc344-ae13-47f8-8b43-a0535e885651': An error occurred while waiting for completion: System.Threading.ThreadAbortException: Thread was being aborted. at System.Threading.Thread.SleepInternal(Int32 millisecondsTimeout) at System.Threading.Thread.Sleep(Int32 millisecondsTimeout) at Microsoft.SharePoint.Administration.SPJobDefinition.WaitForCompletion(TimeSpan timeout) at Microsoft.SharePoint.Administration.SPTimerJobAsyncResult.WaitForCompletion(Object state)

Could this be happening because Distributed Cache service is also not running on server and I tried to fix it but no luck?

  • are you tried to remove it via powershell $spapp = Get-SPServiceApplication -Name "Excel Service" Remove-SPServiceApplication $spapp – Mohamed El-Qassas MVP May 7 '17 at 14:37
  • also try to restart SharePoint Timer Service – Mohamed El-Qassas MVP May 7 '17 at 14:38
  • Yes I have tried Powershell but no luck. Then I had to use stsadm to delete the service application. Restart timer service along with IIS several times. Also did server restart. – Frank Martin May 7 '17 at 14:40
  • Do you face the same issue for all application services or just Excel? – Mohamed El-Qassas MVP May 7 '17 at 14:42
  • Other application services are created and running but I am not sure if I am using any of them apart from may be UPS and Managed Meta Data. – Frank Martin May 7 '17 at 15:34
0

Today I noticed that Excel Service Application that I created yesterday has magically started working. I am not sure how it happened and the only thing I remember is that I disabled anti virus on server and tried creating it again yesterday.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.