0

I have a 2013 test box that I am working on trying to attach a content DB from our 2010 farm. I have mounted the WSS_Content database on the new server. I have made a web app and a site collection named the same as on the live box. However I can't see any sites and the urls don't work.( i get an xml parsing error) I feel like I missed a step somewhere. I am able to make a new web app and site collection with a new DB on the test box and that all works, I can get to the sties I make, but I can't seem to get any sites from the old DB that I mount. I was checking IIS settings from the old box to the new box and as far as I can tell, they are the same. The settings seem basic in IIS, just HTTP and port 80. Since I can make new sites just fine on the test box I feel like there is something I am missing in the database attach process.

I think I don't understand a concept or missed something, does anything jump out at you? There is one top level site in the old content DB and all the other sites are child sites from http://ourIntranet.com/home.aspx I have created a web app, called ourIntranet, with the default app pool and settings. Then I attached the old content DB and detached the new database sharepoint created. I then made a site collection named ourIntranet. But I can't see any content and the url's don't work. I have reset the server and IIS several times just to be sure.

To go into as much detail as I can; I installed SP 2013 and sql server onto a test box. I didn't run the farm config wizard. I set up the user profile service to crawl the AD domain. I made a web app with the same name as on the 2010 farm. I tried to test mount the old content database and got a lot of errors about missing features. I had no choice but to go into the database and delete these, since I had no way of re installing the missing features, since they were uninstalled from the farm before I got here.(there were no features in central admin on the 2010 farm)

after three or four passes, I got zero errors on the test-spDatabase command, so I mounted it for real, with the web application I set up as the target. This actually went fine, with zero errors. I did an IIS reset on the site. Then I went to go to "home.apsx" on the test farm but got a http ok message. I then went back to a snapshot, created the site collection, deleted the default database that was created when I created the web app and ran the database attach again. I haven't done much in IIS, which is why I feel like I need to do something there? I also forgot that I have my test server to not register in DNS, to prevent people from getting to the test site instead of live. If I put the url in the host file on the test server, could that help? (if this ends up being a simple DNS error I will be embarrassed !)

  • It would be good if you can tell us what you have done in detail, describe the steps you have taken. When attaching an database you do not need to create any new site collection, as the infrastructure in the old database will be the same when attached to a 2013 farm. And the reason your URL won't work is because you maybe haven't made a DNS entry? Write what steps you've taken and i try to help you from there. – Christoffer Jul 23 '14 at 20:15
  • I'm glad to hear you say that I don't need to create any site collections, as I was not doing that before. (I had asked that question and not gotten a response) – ryangillis72 Jul 23 '14 at 20:21
1

To migrate a Database from 2010 to 2013. You have to follow these steps.

  • Create New Web Application in 2013 and Configures the AAM
  • Detach the Database which you created while web application creation.
  • Now restore the 2010 db into 2013 SQL server and mount it to the Web Application.

Now go the central admin > Application management > view all site collections. On this page, select the Web Application from right side drop down and now you will see all site collections here.

let me know if it is still not working.

  • I just did all of that again, after I attach the DB I see the database in the content database page in central admin, but the number of site collections says 0 and when I go to view all site collections, nothing shows up. – ryangillis72 Jul 24 '14 at 16:21
  • that's bad, do you have anyother database attached to that web app? or an other copy this database attached to the farm? – Waqas Sarwar MVP Jul 24 '14 at 16:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.