4

All I found a couple other posts related to my issue but they did not lead to any solutions and my backstory is a bit different.

Backstory: We have a 2013 farm that we use for test/development. The name of the SQL server it points too is a SQL alias. We needed to move the DBs to another SQL server so I set the alias up on the new server and pointed the DNS to it. So, the DBs have been moved to the new SQL server and as far as SharePoint is concerned, the name never changed.

Problem: I’m now receiving the dreaded “Sorry, this site hasn’t been shared with you” error for the root URL only. If I go to //RootURL/SubSite it works.

The welcome page is a publishing page. Normally, if you open a browser to //RootURL.Domain.Local , it opens //RootURL/pages/Welcome.aspx. Now, if I enter the full path to Welcom.aspx it works but if I just put in the root URL I get the error.

I’ve reviewed the SQL security and all seems good. But I would think that if this were an actual security issue then I shouldn’t be able to access the sub-sites.

I am listed as a farm administrator and I’ve tried the using the SP farm account and it has the same problem.

I’ve tried tracing the ULS logs while accessing the root address but not seeing any errors jump out.

We haven’t changed anything else on in the farm so I’m at a bit of loss as to why I’m getting this error. Any assistance on things to check would be greatly appreciated.

Thanks - Bill

EDIT: AAM Settings:

Internal-//"serverIP" / Zone- Default / Public- //rootURL

Internal-//"ServerName" / Zone- Default / Public- //rootURL

Internal-//rootURL / Zone- Default / Public- //rootURL

  • How about the Alternate Access mapping can you share your web application alternate mapping settings from central admin? – allegro octopus Dec 3 '15 at 21:33
  • did you detach the content DB and re attach it? also IIS reset. – Waqas Sarwar MVP Dec 3 '15 at 21:37
  • AAM settings added above – Bill Dec 3 '15 at 21:54
  • I've tried both detaching and reattaching the content DB and doing a full restore – Bill Dec 3 '15 at 21:55
  • did you clear the config cache on the servers? what authentication you are using, Kerberos? – Waqas Sarwar MVP Dec 4 '15 at 6:34
1

Resolved I was able to resolve this by removing then rebuilding the web application in CA.

Thanks for the help. - Bill

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.