0

I have a SharePoint Farm that consists of five servers:

1-DB 2-Web FrontEnd & Distributed Cache servers 2-Application & Search Servers

I have configured one of our domain servers to be an RMS server. After, installing the RMS service on the server, I tried to add it to SharePoint but I got the following error:

The required Active Directory Rights Management Service Client (MSPIC.DLL) is presenet but could not be configured properly. IRM will not work until the client is configured properly.

I have searched the web for the solution but to no avail.

I have tried to give permissions to the farm and web application account on ServerCertification.asmx I have also tried importing the certificate for the SharePointAdministration account.

I have checked the event viewer log and I have the following errors:

Event ID 8321 A certificate validation took xxxxx milliseconds ...
Event ID 6398 The Execute method of job definition Microsoft.Office.Server.UserProfiles.LMTRepopulationJob threw an exception ...

Thank you in advance!

1

In addition to giving the Web Application Pool account and the SharePoint Farm account the permission to read and execute _wmcs\certification\ServerCertification.asmx, I have done the following:

The name of the certificate must match the new of the RMS server. e,g: if the RMS server is called RMS.abc.local then that should be the name of the certificate as well.

I have added the certificate to the trusted root authority in all of my SharePoint servers.

I have then installed the RMS Analyzer tool which checks your configuration and corrects all the wrong configurations, if any. from this URL:

https://www.microsoft.com/en-us/download/details.aspx?id=46437

Finally, I have reset the MSPIC settings by following the instructions mentioned in this great article:

https://social.technet.microsoft.com/wiki/contents/articles/19251.ad-rms-troubleshooting-reset-the-client-msipc.aspx

I am not sure if one or all these steps are what fixed my problem. Nonetheless, I hope that they benefit anyone who may face the same problem!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.