0

People search results show either "My Colleague" or "My Colleague's Colleague" under some users profile picture.

  • What is this setting?
  • Why does it appear?
  • How can it be removed?

enter image description here

enter image description here

0

What is this setting?

It's My Colleagues policy in User Profile Sync Service that working when you have configured My Site. check also Add new colleagues and manage your colleague list.

Why does it appear?

by default, the colleague's scan policy is enabled.

How can it be removed?

You can disable My Colleagues policy as the following:

  • Open Central Administration > Application Management > Manage Service Applications
  • Click on User Profile Sync Service. from the above ribbon click Manage.
  • Below People, Click on Manage Policies.
  • Search for My Colleagues, Click on it to edit its setting.
  • Below the Policy Setting, Select Disabled.

enter image description here

| improve this answer | |
  • In SharePoint 2010, I have My Colleagues - Colleagues on My Site, Auto-population of colleagues from organizations and Colleague Recommendation. The Policy Setting for "Colleagues on My Site" is grayed out and I can't change it to Disabled. – C1TonyB Sep 12 '18 at 20:13
  • Make sure the current user is farm account and open central admin as administrator! – Mohamed El-Qassas MVP Sep 12 '18 at 20:19
  • Still unable to change setting after verifying current user is a farm account and opening CA as administrator. – C1TonyB Sep 13 '18 at 11:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.