1

I have a People Search set up on my SharePoint site.

The User Profile Sync service is set up to 'Use SharePoint Profile Synchronization'.

About a week ago, all users were coming into SharePoint and the People Search web part beautifully. Then I had to test a group policy in Active Directory and I pulled two users out of the 'Normal User' group and put them in a test AD group (yes, I needed real users to test). They no longer appeared in the People Search, which I expected. I finished my test and put the two users back into the proper group within Active Directory. Now I cannot get these users to come back into my People Search within SharePoint.

So far this is what I know - 1. When I go into the CA - User Profile Sync Service Application - Edit Synchronization Connection and 'Populate Containers' the users I am looking for are part of the correct User Group and are selected. 2. Under the same User Profile Sync Service Application I can go to 'Manage User Profiles' and search for the users and they both come up as having Active Profiles. 3. The Search Service Application is set up to run a Continuous Crawl.
4. Changes to existing users are coming through the People Search webpart fine. For example, yesterday a telephone number changed. The change was made in Active Directory the new number came through into the People Search.

What else can I do to trouble shoot this?

  • 1
    Can you try doing a full user profile import and a full search crawl? – Eric Alexander Dec 12 '13 at 17:00
  • The Search Service is set to run a continuous crawl. Can I just kick off a full crawl anytime with this running continuously? (I have another post regarding this question specifically if you are able to help) sharepoint.stackexchange.com/questions/85040/… – nicoleBC Dec 12 '13 at 17:31
  • I haven't gotten my hands on 2013 yet, I would assume in Central administration you can do manual full crawls then enable continuous crawling again. – Eric Alexander Dec 12 '13 at 18:30
  • As Pirate Eric stated, A Full User Profile import or a full search crawl should be kicked off manually. Keep your scheduled incremental crawl as is. – Haroun A. Dec 12 '13 at 19:08
  • 1
    You can run a Full Crawl on top of the Continuous Crawl simultaneously. – Mike Dec 12 '13 at 19:10
1

After using this resource to help trouble shoot this issue... http://technet.microsoft.com/en-us/library/ff681014.aspx

We discovered that when looking at the user profiles, the Profile Sync uses the AD name to create users instead of the Netbios name. To fix this we --

  1. Used this resource to enable the Netbios Domain name http://social.technet.microsoft.com/wiki/contents/articles/18060.sharepoint-20xx-what-if-the-domain-netbios-name-is-different-than-the-fqdn-of-the-domain-with-user-profile.aspx
  2. Deleted the User Profile Sync and recreated the connection (This deleted all users and then re-added them - but didn't wipe out their sites).

Problem solved, all users now appear in the people search/staff directory.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.