I have multiple deactivated AD users that appear when searching the employee directory in SharePoint 2010. Clicking the user name generates "User not found."

  1. Users have been deactivated in AD with all Organization information removed.
  2. Users do NOT appear in CA - User Profile Service Application - Manage User Profiles - Search by username or AD account name.

How can I remove these users from the employee directory?

2 Answers 2


You can exclude the AD disabled users to be shown in SharePoint by configuring the UPS setting as the following:

  • In the User Profile Sync service setting.
  • Click on Configure Synchronization Connection.
  • Edit Current Connection.
  • At Exclusion Filter, set it as shown below to exclude the AD disabled users

enter image description here

  • Start Full Sync.

If the above steps didn't help, try to manually Delete Users from SharePoint using PowerShell

  • Thanks Mohamed. Filter already set so I followed the instructions in the link and deleted users under "People and Groups - All People" but the users still appear when searching Employee directory. So I ran the powershell script which returns "You must specify a valid user object or user identity." I assume this means the user has been deleted from the userinfo table. Any other thoughts?
    – C1TonyB
    Aug 17, 2018 at 14:21
  • Have you started Full Sync? Aug 17, 2018 at 14:30
  • Sorry. Yes a full sync. The sockets message is related to full crawl.
    – C1TonyB
    Aug 17, 2018 at 14:58
  • Using MSSMS, I connected to the content database - userinfo table and the user account is still in the table even though the powershell command said "You must specify a valid user object or user identity." I originally used a farm admin account that has access to the database. Any thoughts?
    – C1TonyB
    Aug 17, 2018 at 15:39

This was related to crawl failing. My fix/workaround is: I extended the https site to http, turned off crawl on https and crawled the http site.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.