1

Search by People in SharePoint 2010 generates:

Unable to display this Web Part. To troubleshoot the problem, open this Web page in a Microsoft SharePoint Foundation-compatible HTML editor such as Microsoft SharePoint Designer. If the problem persists, contact your Web server administrator.

Switching to "All Sites" under search returns results. I can open the site in SharePoint Designer but not sure where to go from there.

Site: /sites/Search/Pages/peopleresults.aspx

I removed and added People Search Core Results it causes the same issue.

Any thoughts on how to resolve this issue?

UPDATE: The issue appears to have started after installing the December SharePoint updates.

2

I implemented the solution in the link below and people appear in the results.

https://support.microsoft.com/en-us/help/4052414/loading-behavior-no-longer-available-in-search-results-web-part

0

I have this exact same problem, after the December 2018 updates. I was able to remove a .Net update, which did not resolve the issue. The SP 2010 updates cannot be uninstalled. Other things I've tried, which have NOT worked:
- Restart servers
- Open the page peopleresults.aspx in SP Designer and save it.
- Edit the web part settings, like Display, Results Query, Appearance, Layout, etc.
- Created a new page with only the "People Search Core Results" web part.
- Changed XsltTransformTimeOut

 PS C:\Users\someone>  Add-PSSnapin
 Microsoft.Sharepoint.Powershell
 PS C:\Users\someone> $farm = Get-SPFarm
 PS C:\Users\someone> $farm.XsltTransformTimeOut
 1
 PS C:\Users\someone> $farm.XsltTransformTimeOut = 5
 PS C:\Users\someone> $farm.Update
<snip>
 PS C:\Users\someone> $farm.XsltTransformTimeOut
 5

- Checked web and SP log files, and event viewer, for additional information about the error.

Right now we are about to declare this part of the search unfixable. The "All Sites" search still works, and it shows "People Matches" in the right side column of the search results. We also have Lync to find people, but many prefer using this feature in SP.

I can't spend too much more time on this, but if I find anything I will make an update here. We're getting closer to begin migration to SP 2019.

Found others having same issue in TechNet forum, People Search Not Working.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.