I click on Start Profile Synchronization (Full or Incremental) and nothing happens. It never shows it going through the different sync stages.

  1. Running with farm account that has full rights
  2. SharePoint 2010 with SP1 and October 2011 CU installed and upgraded successfully
  3. No errors given in the logs, just a log that it started, then nothing
  4. running FIM Sync Service manager shows it starting, in-progress and finishing within about 30 seconds. The Sync Stats are all 0s except for Unchanged: 1.
  5. In FIM, Step Type is: Full Import (Stage Only)
  6. I've recreated the service application, restarted the service, restarted the servers many times.
  7. Synchronization Connections are properly configured with AD. The proper OUs are selected.

How can I figure this out? It seemed to be fine before the installation of October 2011 CU. Is that the cause of it?

  • Silly questions, but have you configured a connection to your directory? If so, when configuring it (I'm assuming through the GUI) were you able to drill down and select an OU for importing?
    – shufler
    Nov 29, 2011 at 18:54
  • Yes I did. I will add that to my question, just to be comprehensive. Thanks! :)
    – Shane
    Nov 29, 2011 at 18:56
  • FWIW Tt my knowledge this CU doesn't introduce an issue like this (I have the Oct 2011 CU installed in a few farms). Is the synchronization service started?
    – shufler
    Nov 29, 2011 at 19:03
  • @shufler Yes, both User Profile Service and User Profile Sync Service are Started successfully in "Services on Server"
    – Shane
    Nov 29, 2011 at 19:06

3 Answers 3


You did not mention if this is a multi server farm. I have seen this behavior when you have the service running on more than one server. In Central Administration go to Services on Server and ensure that the User Profile Sync Service is only running on one server. Once you stop it on all servers, provision it on just one server in the farm.

LMK if this helps.


  • Interestingly, the User Profile Sync service was only running on our App server, however, the User Profile Service was running on our app and two webservers. I stopped that service on the two web servers and it started working. Thanks!
    – Shane
    Nov 30, 2011 at 18:44

I was just fighting with this this morning. I had everything setup just like you do. I finally had to explicitly give "Allow login locally" rights to my service account and that solved the issue.

  • The sync service runs under farm account. The farm account needs log on local rights to work properly as specified on technet and in Spence Harbars guide harbar.net/articles/sp2010ups.aspx Nov 29, 2011 at 22:17
  • Based on Shane's points, my assumption (and Shane can correct me if I'm wrong) is that the farm account has this right as it sounds like it previously worked.
    – shufler
    Nov 29, 2011 at 22:20

Granting the Replicate Directory Changes AD permission to the SP_Farm account (timer service account) fixed this issue for me. Follow the instructions in this KB article:


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.