1

I have created a custom content type for our company's projects. It is a document set with some columns for basic project information: customer, assembly, etc. At first I set these columns to be "required" so that people wouldn't skip filling out information.

But people started adding documentation to their project folders and nobody else was able to see it. This is because when documents are added, they are checked out until you fill out all the required column information properties (a step already completed when creating a new document set). It doesn't make much sense to have people filling out the same information over and over again, especially if your projects contain hundreds of documents.

I wanted to make the columns "optional", but then I'm not able to take advantage of content organizing rules, which need columns to be set as "required" to work.

How can I have all documents within a document set automatically inherit the properties of the document set? My intuition is that you can either add custom javascript or a third party add-in, but I haven't had any luck in my searches in this way. Maybe I'm just going about this the wrong way altogether. Any suggestions?

1

How can I have all documents within a document set automatically inherit the properties of the document set?

That is a key feature of Document Sets. When you create your custom Document Set, by inheriting from the default Document Set, you can specify the list of properties of the Document Set and if they will used to auto-populate documents.

When you create your Document Set Content Type, add the columns for the doc set:

enter image description here

Then in Document Set Settings select the columns to auto update:

enter image description here

So go to Site Settings, Site Content Types, edit your document set Content Type and click Document Set Settings and checkmark the fields to auto update.

| improve this answer | |
  • I was in the middle of posting this same answer. This is correct. +1 – Jammin4CO May 1 '18 at 20:46
  • So I think what happened was I had checked those boxes to begin with, but when I added a new column type to the document set it defaulted to unchecked. Once I changed that (and activated the site content organizer based on metadata feature) it worked. Thanks for pointing me in the right direction. – Sigma May 2 '18 at 15:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.