0

I had restored my SharePoint 2013 on-premises site to another server. All the things got configured correctly but not for a reusable workflow which is SharePoint 2010 workflow.

This workflow uses Custom SharePoint Activities which I already re-deployed to the new server in GAC. Web application feature is activated for it and also these custom activities are available in SharePoint Designer if try to add any new condition. Content type columns are also available in workflow.

But when I try to publish this workflow, this gives me following error:

Errors were found when compiling the workflow. The workflow files were saved but cannot be run.

(0, 10) The type or namespace name 'DP' could not be found (are you missing a using directive or an assembly reference?)) (4321, 16) The type or namespace name 'DP' could not be found (are you missing a using directive or an assembly reference?))

So How can I bind this existing workflow again to the list as it was on previous environment?

0

Open your site in SharePoint Designer and navigate to the List name where you expect this workflow to be attached to. Under 'Workflow' tab you will see if this workflow is attached to the list or not. If Not you will need add the workflow from existing and attach it.

  • I checked in SharePoint Designer --> List settings --> workflows tab, my workflow in not listed there. If I try to do Associate Existing Workflow available in ribbon, there also my workflow is not listed. To make it available in the existing workflows list, I am trying to publish it but its giving me error which I mentioned in my question. – Yayati Dec 22 '16 at 6:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.