1

I have created a reusable workflow in SP D 2013 against my custom content type[parent is document CT].But when I published and started trying to upload a document into the document library where this custom content type is associated, am unable to open the edittaskform for the approvers to assign the task.

am getting the below error:

The form cannot be rendered. This may be due to a misconfiguration of the Microsoft SharePoint Server State Service. For more information, contact your server administrator.

I didn't use the Tasks list for associating this workflow, as I have "project site[* PROJECTSITE#0 *]" tasks are being entered for a different purpose.

Errorinworkflowtaskslist

EDIT

Now i have created state service application, but its not fully enabled. when i put a hover / mouse over, am not able to get the handsymbol and not able to open the stateserv.appln page

enter image description here

  • 1
    Is the SharePoint State Service configured and running in your farm? By default it is not. – Cornelius J. van Dyk Mar 10 '16 at 9:04
  • Thank you, that's what ia m doing now. I have created a new state service, its not working properly , so am now trying to delete the created one and recreate anew one . – userAZLogicApps Mar 10 '16 at 10:03
  • Am going through this blog for creating a state service, but am confused about the application pool and service appln db.njbblog.blogspot.in/2012/11/… – userAZLogicApps Mar 10 '16 at 10:05
  • 1
    I am all for using PowerShell, but maybe just try the Configuration Wizard instead? The UI should guide you. technet.microsoft.com/en-us/library/ee704548.aspx – Cornelius J. van Dyk Mar 10 '16 at 10:11
  • In the new service application drop down in central admin, am not able to see the state service application menu item. – userAZLogicApps Mar 10 '16 at 10:19
1

Couple of things you should have to ensure,

If you have problem with state service application then delete it from CA (while deleting it, select check box "Delete data associated with the Service Applications" to delete associated DB) & Create new state service application. there are two options for creation,

  1. Central Administration

Go to Central Administration-->Configuration Wizards-->Launch the Farm Configuration Wizard-->Start The Wizard-->Check the State Service and hit Ok

This will create the State service using GUI. OR

  1. PowerShell:

    $serviceApp = New-SPStateServiceApplication -Name "StateService"
    
    New-SPStateServiceDatabase -Name "StateServiceDB" -ServiceApplication $serviceApp
    
    New-SPStateServiceApplicationProxy -Name "StateServiceProxy" -ServiceApplication $serviceApp -DefaultProxyGroup
    

Once State service application is created successfully. check following things,

  1. Go to CA and Ensure that the State Service is started.

  2. Navigate back to Central Administration --> Application Management --> Service Application Associations--> Select your web application and Check your state service application check box is selected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.