2

I Installed All prerequisites successfully on my server but when I am running sharepoint 2013 setup, It is giving me below error:

A System restart from a previous installation or update is pending.Restart your computer and run setup to continue

Please guide me what should I need to do for resolving it.

below is the screenshot of it

http://i.stack.imgur.com/54KZs.png

1
  • 1
    Have you restarted your machine? If not then please restart the machine. It is strongly required. After restating the machine, try to run SharePoint setup, it will install without any error. Sep 25 '16 at 11:58
3

Have you restarted your machine?

If not then please restart the machine. It is strongly required. After restarting the machine, try to run SharePoint setup, it will install without any error.

After restarting the machine if still it gives same error then follow the below steps:

Check the value of the following Registry keys:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\UpdateExeVolatile - if the value of the UpdateExeVolatile Registry key is anything other than 0 you will see this message.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\PendingFileRenameOperations - if the PendingFileRenameOperations Registry key has any value you will see this message.

To remove an orphaned UpdateExeVolatile registry key value

  • Open a registry editor, such as Regedit.exe or Regedt32.exe.
  • Navigate to HKLM\SOFTWARE\Microsoft\Updates\
  • In the right navigation pane, double-click the UpdateExeVolatile key.
  • Configure the key with a value of 0
  • Close Registry Editor.

To delete the orphaned PendingFileRenameOperations registry key

  • Open a registry editor, such as Regedit.exe or Regedt32.exe.
  • Navigate to HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\
  • In the right navigation pane, right-click the PendingFileRenameOperations key and selectDelete.
  • Close Registry Editor.

Delete the InProgress registry value

  • Open a registry editor, such as Regedit.exe or Regedt32.exe.
  • Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer.
  • Right-click the InProgress value and select Delete from the context menu. When prompted, click Yes to confirm the delete operation.
  • Close Registry Editor.

Restart your computer and attempt to run the installation again.

2
  • I deleted as per your post but still issue is coming any other thing should i check?
    – akj
    Sep 25 '16 at 12:38
  • I have updated my answer. Please check it. Sep 26 '16 at 4:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.