0

I tried to install SharePoint 2013(15.0.4420.1017) on Windows Server 2012 R2 using the AutoInstaller script inside HyperV.

The prerequisites installation completes successfully, but when the SharePoint server installation starts I'm getting the following error:

Microsoft Setup Bootstrapper has stopped working

I have tried the below options

  • Disabled Dynamic memory allocation
  • Increased the number of virtual processors(1 to 4)

Does anybody have a solution for this?

1
  • How much Memory did you assign to your SharePoint VM? Is there anything else installed (e.g. SQL-Server)?
    – MHeld
    Oct 20, 2018 at 21:52

2 Answers 2

2

Try to do the following:

  • Make sure that the Max degree of parallelism is set to 1 in SQL Server Properties.
  • Take a copy from the SharePoint Media to a writable location in your Hyper-V.
  • Download SharePoint Server 2013 with Service Pack 1 fix
  • Extract the downloaded folder > Copy the svrsetup.dll file to the Root SharePoint Setup” folder. as mentioned at SHAREPOINT 2013 SETUP UNABLE TO PROCEED
  • Now, Run the SharePoint Installation file without auto-installer script to make sure everything is OK.

  • If the key dialog is shown, cancel and run the auto-installer script.

1
  • 1
    I just ran into this issue not long ago and this is the answer
    – lazoDev
    Oct 22, 2018 at 17:06
0

Follow up answer here since the above workaround didn't apply and I still got error after downgrading to .Net 4.5 on Server 2012 R2:

Check the SharePoint Server Setup(date).log file in %userprofile%\AppData\Local\Temp. You may have an incorrect version of the pre-requisites. For me it was WCF 5.6 is missing, but 5.0 was installed.

Then I discovered that 5.6 has recently (at least August 2021) been pulled from the internet so I had to use the WayBack machine to find a working download.

Log snippet:

2021/10/08 14:44:22:581::[3312] Microsoft WCF Data Services version 5.0.51212 installed.
2021/10/08 14:44:22:581::[3312] Minimum version of Microsoft WCF Data Services 5.6 is not installed.
...
2021/10/08 14:44:22:815::[3312] WER element [P6] is set to value [Failed to load resource : %i]
2021/10/08 14:44:22:815::[3312]  WER element [P6] is converted to [CE18111C]
2021/10/08 14:44:22:815::[3312] Error: Failed to load resource : 4085 Type: 72::ResourceNotFound. 

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.