We are trying to install SP 2016 on server and on setup instruction it is giving below 2 errors.

  1. A system restart from previous installation or update is pending. Restart the computer and run setup to continue.

2.This product requires asp.net v4.0 to be in list of Internet information services, if it is not install in list re-install Asp.net v4.0​

For Error 1 - After restart and directly running setup, it is still showing this error. sometimes it is gone but comes back again sometimes. is there any flag somewhere which controls this parameter or restart ?

For Error 2 - ASP.NET 4.5 is installed and .NET framework version 4.6 is also installed, still it is giving this error.

In IIS - Application pool shows ASP.NET v4.5 is installed.


In IIS - ISAPI options shows v4.0 is available and added in list of IIS.


Request for help/ideas to troubleshoot.

2 Answers 2


Finally found the solution in one link thought it was SP 2013 it worked in SP 2016 also., Posting answer for others...

When checked pre-requisites log files, we see below error was logged.

“error when enabling asp.net v4.0.30319”

I tried various things to attempt to resolve this including adding roles and features manually as well as attempting to register ASP.NET 4 using command:

%windir%\Microsoft.NET\Framework64\v4.0.30319\aspnet_regiis.exe -i –enable

The above proved unsuccessful and then came across this forum on TechNet http://social.technet.microsoft.com/Forums/en-US/sharepointitpropreview/thread/94b98c03-842e-4b2e-8707-8652774d73a3/


The solution was to remove the Windows Server 2012 from the DOMAIN, it should be part of work group. Then ran the install able and error was gone :) After installation, added server back to domain before running configuration wizard. this is required because wizard would need domain account if you are planning to have database server on another machine.



Go to Server Manager - Add Roles And Features - check all checkboxes under Web server - Restart the server

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.