Installation of prerequisites for Sharepoint 2013 server x64 (on Windows Server 2008R2, 12-core physical server) succeeded, but Sharepoint breaks installation and installation rollbacks on the following error (fragment from the installation log file):

 2013/05/20 14:57:10:116::[1744] Error: Failed to install product:  G:\global\oserver.MSI ErrorCode: 1603(0x643). 

and it seem to start a bit higher in the log with:

 2013/05/20 14:57:10:054::[1744] MSI(ACTIONSTART): 'Action 14:57:10: ArpWrite. '
 2013/05/20 14:57:10:054::[1744] MSI(INFO): 'Action start 14:57:10: ArpWrite.'
 2013/05/20 14:57:10:100::[1744] MSI(INFO): 'CustomAction ArpWrite returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)'
 2013/05/20 14:57:10:100::[1744] MSI(INFO): 'Action ended 14:57:10: ArpWrite. Return value 3.'
 2013/05/20 14:57:10:100::[1744] MSI(INFO): 'Action ended 14:57:10: INSTALL. Return value 3.'

The only hint (solution?) I can find is modyfying installer and disabling ArpWrite action, but it seems really bad idea since I don't even know what effect this action has on installation.

My question is: do you know what might be the cause that ArpWrite does not succeed, or how to find out the error details? Is modyfying the installer the best approach in this situation?

Edit: the solution I linked to above, with disabling ArpWrite action on installer, turned out to work. On our developer environment Sharepoint 2013 has now installed and seem to run fine. Orca can be downloaded here and whole modification of msi file takes no more than 3 minutes. Still, I leave this question open because the effect of this install action remains unknown (though it seems not to be very important).

  • It would be nice if Microsoft actually was willing to look at and fix this problem I have an MSDN package, which comes with support calls. So I opened one on this case. Their proposed solutions have been along the lines of reboot your box, do you have virus protection on your system, etc. Totally useless people. They sat with me and we did the install and watched it fail 3 different times after applying all the service packs that other people in this thread pointed out. They dont work. I have no idea why The ARPWRITE patch has been holding at my site, but it gives me the willies
    – user19765
    Commented Sep 25, 2013 at 18:02
  • Same problem - and I couldn't find any solution. Interestingly I am working with Windows Server 2012 R2. If you had the same problem with 2008 R2 we can probably rule out the OS.
    – lapsus
    Commented May 13, 2014 at 20:38

6 Answers 6


Modifying the installer is not a Microsoft supported solution. The ArpWrite entry actually is used to write the fact that SP was installed into the registry as part of the install.

I ran into this issue on a new install for a client, the server did not have these two patches applied to the server, I noticed they were pending and applied them.

I don't think they changed anything with the server during the weekend, but this may be a good place to look first...

KB2768703 and KB2770917 should be applied and may resolve this issue on Windows Server 2012. Although, in looking at the two the KB2768703 patch seems more related to DRM / media issues. I'd recommend trying KB2770917 first as it is a roll-up of many.


I worked with Microsoft Engineers to find the root cause of the error. We discovered a missing registry key at HKLM:\SOFTWARE\Policies\Microsoft\Windows\Installer

I wrote a fix script and posted it on our Blog: http://www.devfacto.com/resolved/

For me the value of the string was warmupx (with the x on the end) and the debug value was 7 that worked, at long last

  • 2
    I can confirm that this is needed on a new 2012 R2 + SP2013 SP1 install. I tried the other answers here (changing region, patching windows) but adding the registry keys is the only thing that worked. Thank you for saving the day.
    – pauska
    Commented Feb 8, 2016 at 17:33
  • Yes, this voodoo actually did the trick.
    – Arthur
    Commented Mar 30, 2016 at 9:50
  • @Dragan ,I really disappointed that you didn't mentioned you must put registry path in single quotes!! Commented May 7, 2016 at 18:29
  • @JalaliShakib I'm sorry that you had troubles. I re-ran the script we have posted on the blog site on a fresh machine, and it is working for me without quotes. Commented May 9, 2016 at 16:31
  • @DraganRadović ,I also separate each section of the path with \ and after that i put it in quotes, and all got worked. But it seems separating with \ is enough. Thanks for correcting it. Commented May 10, 2016 at 5:07

I had the same issue. I tried installing Sharepoint without installing Office. After installing Office my issue was resolved.


UPDATE: Unfortunately I wasn't able to reproduce this - I'm stuck again! :<

I don't know how to put this, but...

using a Standard license key rather than an Enterprise license did the trick for me.

2014/05/13 22:49:15:213::[1228] MSI(INFO): '=== Logging stopped: 13.05.2014  22:49:15 ==='
2014/05/13 22:49:15:250::[1228] MSI(TERMINATE): '<NULL>'
2014/05/13 22:49:15:250::[1228] PERF: TickCount=1529640 Name=MsiPackage::Install Description=Returned from OMsiInstaller::InstallProduct
2014/05/13 22:49:15:250::[1228] Successfully installed package: oserver > path:D:\global\oserver.MSI

I ran into this same issue recently installing the Enterprise version of the product on Windows Server 2012 R2, this issue was resolved for me configuring a different location in control panel under region. i.e: from Spain to Mexico. Hope it helps.


I have an answer that may work for many of you. Check the Power Options in the server BIOS and change from Performance to Balanced. This was the fix for a similar reported issue when installing Office Web Apps, and it worked for our Sharepoint 2013 install after many, many frustrating hours.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.