SharePoint 2013, SSRS 2013 SharePoint integrated mode. Document library with correct content types for SSRS. Workflow on that library set to run on "new item" and "edit item". Workflow is set to a legacy (2010 ) workflow type.

User creates report using BIDS (Business Intelligence Development Suite). They publish the report from BIDS to that library and worflows fails with error: "Workflow XXX was canceled by System Account"

Diagnostic logs contain message: AutoStart Workflow: Microsoft.SharePoint.SPException: Recursive workflows are not permitted. at Microsoft.SharePoint.Workflow.SPWorkflowAutostartEventReceiver.<>c__DisplayClass1.b__0(SPSite superUserSite, SPWeb superUserWeb)

The workflow does not contain anything recursive. It does however contain the "Impersonation Step" to run as the workflow author.

If the user saves RDL local and manually upload file, the workflow runs just fine.

Has anyone come across SSRS reports being published via BIDS not triggering workflows and if so, have they found a resolution for it? Or is it the "impersonation step" causing the issue (I will be attempting to test this theory shortly myself).

Additional Information: Not a recursive issue. I have a workflow, single step. "set workflow variable" and I have the same issue. Still can't get "on change" or "on create" even to trigger when item published from BIDS.

Get the error:

RunWorkflow: Microsoft.SharePoint.SPException: <Error><CompilerError Line="1" Column="1" Text="The root activity type is invalid." /></Error>    
 at Microsoft.SharePoint.Workflow.SPNoCodeXomlCompiler.LoadXomlAssembly(SPWorkflowAssociation association, SPWeb web)    
 at Microsoft.SharePoint.Workflow.SPWinOeHostServices.LoadDeclarativeAssembly(SPWorkflowAssociation association, Boolean fallback)    
 at Microsoft.SharePoint.Workflow.SPWinOeHostServices.CreateInstance(SPWorkflow workflow)    
 at Microsoft.SharePoint.Workflow.SPWinOeEngine.RunWorkflow(SPWorkflowHostService host, SPWorkflow workflow, Collection`1 events, TimeSpan timeOut)    
 at Microsoft.SharePoint.Workflow.SPWorkflowManager.RunWorkflowElev(SPWorkflow workflow, Collection`1 events, SPWorkflowRunOptionsInternal runOptions)

Additional information: "Root Activity":

<ns0:RootWorkflowActivityWithData x:Class="Microsoft.SharePoint.Workflow.ROOT" x:Name="ROOT" xmlns:ns1="clr-namespace:Microsoft.SharePoint.WorkflowActions.WithKey;Assembly=Microsoft.SharePoint.WorkflowActions, Version=, Culture=neutral, PublicKeyToken=null" xmlns="http://schemas.microsoft.com/winfx/2006/xaml/workflow" xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml" xmlns:ns0="clr-namespace:Microsoft.SharePoint.WorkflowActions;Assembly=Microsoft.SharePoint.WorkflowActions, Version=, Culture=neutral, PublicKeyToken=null">

I have looked through the logs even further and found nothing more, even with "Legacy workflow" traced turned to verbose.

There are some strange SSRS related messages, starting to wonder if it is an SSRS issue not a workflow issue.

  • When you say they are publishing it via BIDS, is it sending an email to the list? It's been about 5 years since I've used BIDS so I'm a little fuzzy. Also are the published fiels coming over as the System Account? Jun 11, 2015 at 20:58
  • BIDS is really report designer (but Visual Studio). That means there is a "build and deploy" scenario where it save the RDL and any RSDS or other components to the document library. They get published as the actual report designer. The "created by" displays the report designers name. I suspect that the "publish" uses the SSRS service app in some fashion - web service call - and that is what is causing an issue. Jun 11, 2015 at 21:12
  • Ah ok, I remember we woud have all the RDLs and datasources housed on the SSRS side and then schedule the report execution to dump the files into a a document library or email them into a document library. Jun 12, 2015 at 1:12

2 Answers 2


Old article but still relevant SharePoint 2007 Service Pack 2 prevents an on-change workflow from starting itself


  • Thanks, I will have the workflow creator check that. I normally remind my client about that issue, but did not even think about that in this case since it worked on upload. SharePoint may "check for recursive" differently. Thanks, Jun 12, 2015 at 19:48
  • I have the same issue as @EricVanRoy. The article is really interesting, I'm just not sure how I might implement it to solve the issue here, where deploying from BIDS isn't triggering my workflow, but instead giving error, "Workflow XXX was canceled by System Account". How would I implement this co-recursive, post SP2 solution to solve this?
    – russds
    Jun 12, 2015 at 21:13
  • Not recursive issue. See additional information above Jun 15, 2015 at 20:19
  • Hmmm, maybe I'm too noob to follow the information above :). Did you find a solution to this @EricVanRoy? We have a lot of document library's with reports (rdl files) in them and basically I'm not able to create workflows to send an email when those document library's are updated because I get the same error outlined in your initial question. Is there any way to trigger a workflow when a document library of rdl files is updated?
    – russds
    Jun 19, 2015 at 16:12

SharePoint Designer 2013 list workflow stops with message "The root activity type is invalid. https://social.technet.microsoft.com/Forums/exchange/en-US/70adcc8c-ff2a-494a-a620-02dc55671826/sharepoint-designer-2013-list-workflow-stops-with-message-the-root-activity-type-is-invalid?forum=sharepointdevelopment

  • Thank you, at least I understand a little more. Unfortunately since Visual Studio (BIDS) is what is placing the object in the library, I don't have the ability to change the Visual Studio code. But at least I have a little more validation that I am not alone Jun 16, 2015 at 21:23
  • can you access the uls logs?
    – 1wisegeek
    Jun 17, 2015 at 16:13
  • Main message is above, I will grab some more around it, but nothing too interesting. Jun 22, 2015 at 13:52
  • I have updated the contents above with additional log information. Jun 22, 2015 at 22:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.