0

We are not sure when it started, but we suddenly cannot publish workflows on our SharePoint 2010 Server.

Compilation failed. Could not load file or assembly 'i4kh4nkl, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. Access is denied.

The assembly name changes every time we try to publish the workflow.

Been working on this for about 3 weeks with Microsoft. There are no logs being produced, fiddler grabs the error and correlation id when the workflow fails to publish in designer, but there is no correlation ID in the logs even with verbose turned on.

We think it could be:

  1. McAfee Antivirus
  2. Group Policy
  3. Impersonation Account Issue

Was hoping someone else might have some ideas.

Thanks

  • Have you tried resetting IIS and doing a full profile sync? I had a similar issue and it was related to profiles. – MickB Sep 7 '16 at 20:16
  • Yes we tried that . :( – Brian Rood Sep 9 '16 at 14:22
  • So the solution was an issue with our firewall. Our organization is very large so convincing the Security Division that we needed to test without the firewall on took some time. When I have an exact solution I will post. – Brian Rood Sep 9 '16 at 14:25
0

FYI: Apparently a random folder after \temp can also be generated by the process, aside from random naming of the .dll...

The problem was due to HBSS HIPS - Signature 7020 DISA McAfee – Prevent DLL files from running in User Profile

I added an exception (attached) to our baseline IPS rules policy:

Host Intrusion Prevention 8.0:IPS > IPS Rules (Windows, Linux, Solaris) > EUST Baseline IPS Rules 2016

This solved our issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.