2

I have VisualStudio 2015, and until very recently, the Worflow Designer worked, I could create workflows in VS. I'm not sure what changed, I applied VS 2015 Update 3 back at the beginning of November, and that's the last change I know of to VS itself, and things were still working after that.

Now, when I double-click on a XAML file to edit a workflow, the tab in VS gives me the following error:

System.IO.FileNotFoundException: Could not load file or assembly 'Microsoft.VisualStudio.SharePoint.WorkflowExtensions, Version=14.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified. File name: 'Microsoft.VisualStudio.SharePoint.WorkflowExtensions, Version=14.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'

I found this blog post by Andrew Connell, and ran the little Powershell command he has there, and it does find the DLL at the following path:

C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE\Extensions\WorkflowDesigner

So the DLL is where it should be, as far as I can tell. I tried his solution (close the XAML tab and re-open it), but that didn't work. Just as in the comments on his article, I instead get the error:

System.ArgumentException: An item with the same key has already been added. at System.ThrowHelper.ThrowArgumentException(ExceptionResource resource) at System.Collections.Generic.Dictionary`2.Insert(TKey key, TValue value, Boolean add) at Microsoft.VisualStudio.Activities.EditorPanesManager.OnEditorPaneRenamed(String oldValue, String newValue, EditorPane editorPane) at Microsoft.VisualStudio.Activities.EditorPane.set_FileName(String value) at Microsoft.VisualStudio.Activities.EditorPane.Microsoft.VisualStudio.Shell.Interop.IPersistFileFormat.Load(String fileName, UInt32 formatMode, Int32 readOnly)

I also found this question and answer, and the solution there is apparently to update Workflow Manager and Service Bus on my server. But, they are already the latest versions.

So, before I try re-installing VS, is there any way to get VS pointed back at the DLL that is in the VS Extensions folder?

1

Ok, instead of completely re-installing Visual Studio, I manually un-installed and re-installed Office Developer Tools for VS2015, and that seems to have worked, I can now open a XAML file and see the workflow designer window.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.