2

Several times I have destroyed and re-implemented Search Service Application. I've specified Continuous Crawl, but when I do that, the drop down box for scheduling incremental crawls changes from None to Every 4 Hours.

I usually get one good crawl in that takes somewhere between 20-45 minutes, and I get decent search results. But then another full or incremental crawl begins (according to the logs), and once that happens, the continuous crawl (and the incremental or full crawl) take hours and hours and hours until I finally stop it.

What am I doing wrong here? I just want it to continuously crawl, as advertised.

UPDATE: I'm not certain that I previously articulated my problem correctly, I'm going to try again. I have re-provisioned the Search Service Application and set up my Local SharePoint Sites. Per the recommendation below, I ran a full crawl (which took 28:45) and then I ran an incremental crawl (which took 23:08).

Next, I pulled up the configuration for "Local SharePoint Sites" and selected the option for Continuous Crawl. My problem is that when I select Continuous Crawl, it changes the INCREMENTAL CRAWL interval from None to 'Every 4 Hours.'

Why is it setting up an Incremental Crawl Schedule AT ALL, if I'm selecting Continuous Crawl?

So...when no crawls are scheduled, I can run a crawl in under 30 minutes. But once Continuous Crawls are set up, the crawl takes forever. (I'm already at 40 minutes on the "incremental crawl" that I didn't order).

I don't know how to make this work so that the crawl just works without any intervention. I can't seem to successfully complete more than one full and one incremental crawl without destroying and re-provisioning the Search Service Application, which is not a viable long-term option.

  • when you setup the search, did you run the full crawl 1st followed a couple of incremental? – Waqas Sarwar MVP Apr 30 '15 at 14:47
  • No, I had to choose between continuous or non-continuous. The docs all say that if I choose continuous, then full/incremental don't apply, but that doesn't appear to be the case. – Scott Dart Apr 30 '15 at 14:52
  • as per my experince, after setting up the search you have to run the full crawl first followed by incremental then configure the continuous.see this one.technet.microsoft.com/en-us/library/… – Waqas Sarwar MVP Apr 30 '15 at 14:57
1

I found the information I was looking for. I was missing permissions for the service account that was performing the work.

Specifically, the missing permissions were "Log on as a service" and "Replace a process level token."

I found this blog post to be quite helpful in figuring out my issues. I should also note that due to particular Group Policies in force at my organization, I had to get a Domain Admin to allow my Application Service Account these permissions.

  • If you have already found solution, you can accept that as answers that will mark that this question is having "accepted answer". – John Zachariah Sep 16 '17 at 9:54
1

Just for record:

Following is "as is" from Manage continuous crawls in SharePoint Server 2013

A continuous crawl does not process or retry items that return errors more than three times. A "clean-up" incremental crawl automatically runs every four hours for content sources that have continuous crawl enabled to re-crawl any items that repeatedly return errors. This incremental crawl will try to crawl the item again and then will postpone retries if the error persists.

Hope this helps.

0

As per my experience and recommendation.When you configure a new Search Service application and/or create a new content source then.

  • You have to run the full crawl and followed by incremental crawl.
  • Once it create an index then you can enable the continuous crawl.

As you said, you did not perform the full crawl on the content source then SharePoint automatically kick a full crawl for that content source. Which is happening in your case.

  • "A full crawl of the content source has never been done from this Search service application."

Read this technet which tell you when a full crawl required or automatically kicked.

  • See my update in the main question. I understand that a full crawl is first required, but that's not the issue. The issue is that I can do ONE full crawl, then ONE incremental crawl. Then when I set it to "Continuous Crawl", the logs appear to indicate that an incremental crawl has started, and it runs continuously until I destroy the Search Service Application and subsequently re-provision it. Then I can get ONE full crawl, then ONE incremental crawl, and then we're in a viscous cycle. – Scott Dart Apr 30 '15 at 18:04
  • What crawl log is saying? And did you check the uls logs if their is any hint why full/incremental kicked automatically.... – Waqas Sarwar MVP Apr 30 '15 at 18:13
  • Crawl log shows exactly what I just described. Successfully executed a full crawl, then successfully executed an incremental crawl. After that, I switched to "Continuous Crawl," but then the interface automatically changed the "incremental crawl schedule" to every four hours. If you look at sharepoint24x7.com/2014/07/25/… you'll see that even in that author's illustration, it's changing the "incremental crawl schedule" when one selects "continuous crawl." – Scott Dart Apr 30 '15 at 18:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.