I want to set Incremental Crawl to night but don't finally understand how to do it.

enter image description here

Microsoft says:

If you want to crawl more frequently than once a day, select the Repeat within the day box and type the number of minutes to wait between crawls in the Every box and type the total number of minutes in which to repeat the crawl within the same day in the For box. For example, if you select Repeat within the day and type 60 in the Every box and 720 in the For box, an incremental crawl of the content source you are configuring starts every 60 minutes up to 720 minutes (12 hours) after the first scheduled incremental crawl for this content source ran. https://technet.microsoft.com/en-us/library/cc263373(v=office.12).aspx

But I don't understand it. I want to

  1. Turn off full crawl(it is already indexed)

  2. Set Incremental crawl to night - between by example 9 PM and 8 AM

How can I realize it with these options?

  • Why have several crawls between 9 PM and 8 AM? One crawl should find all changes that happend over the day. For your goal set ) PM Start and then run for 660 minutes. 5 minutes is very short... Try to set it so the crawls don't overlap. Sep 13, 2018 at 12:29
  • Greetings Heiko! '5 minutes' is only sample text for sceenshot. It is very old post, but as I remember there was very large database and low-powered server. I wanted to improve performance and moved search to night interval. Also as I understand, "Incremental crawl" in SP Online and in 2013 is now different from 2007; not sure.
    – Gennady G
    Sep 19, 2018 at 12:41

1 Answer 1


The configuration seems to be alright.

Full crawl schedule is set to 'none' and for incremental crawl, you specified everything correct.

If you want it to run just once per day, untick the "repeat within the day" box.

If you want it to run from 9pm to 8am, keep the box ticked and set values for "every" and "for".

For example: every 5 minutes for 660 minutes (11 hours (from 9pm to 8am))

  • Thank You for response Gintas! Strange options for me(I'm about "every 5 minutes"), but I set like this. Users work in different timezones so I've set "every 5 minutes from 8PM till 5:30AM, for 570 minutes"
    – Gennady G
    May 4, 2016 at 13:12
  • Well, I think there's no need to have incremental crawls running every 5 minutes every night, if there's nobody working overnight, there are no changes, therefore you don't need to crawl it again... And I think you need to run full crawl at least once a week, for example during the weekend... Your configuration is strange :) Do more research about these search crawls, what they crawl and what impact they have on your system :) @GennadyG
    – Gintas K
    May 4, 2016 at 13:16
  • Hi! I know that Full crawl is only used first time(when system is migrated/filled with data), and in case of currupted search index. Then we can use only incremental crawls do add new data. My configuration is strange because there is big performance impact to system and full crawl works for few days(server hangs). Incremental crawl works too for few days. So I try to minimize this impact and move resource-intensive operations to night time. p.s.: maybe then I can set "every hour for 570 minutes"?
    – Gennady G
    May 4, 2016 at 13:23
  • 1
    I would suggest to run full re-index (I know it will take ages for your system, but maybe during some holidays?) and then incremental crawls should be faster... I had huge problems before when the crawls were overlapping... If you set "every 570 for 570" it will still start second crawl in the end, so I suppose it should be something like "every 571 for 570" so there's just one crawl then. The other thing is that they might be taking so long just because they actually overlap. I would set it to "every 571 for 570" and then check how long it took next morning. @GennadyG
    – Gintas K
    May 4, 2016 at 13:43
  • 1
    Ok :) The only thing I know is that overlapping crawls may cause big problems and might even be the reason of your issues. Good luck sorting this out! @GennadyG
    – Gintas K
    May 4, 2016 at 14:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.