1

I have a SP2010 "My Site". When a user edits their profile, in the "Ask Me About" section, there is a semicolon-separated list of terms which the user is supposed to populate. The problem is, though, the user types in some phrase or word, and the result gets "red-lined" and if they try to submit, they get a "The given term is not valid" validation notice in red.

Looking in Central Admin > Manage Service Application> User Profile Service Application > Manage User Properties > Ask Me About; I do see a "Pick a Term Set for this property" dropdown menu. The dropdown menu contains:

  • (blank)
  • Community
  • Project Keywords
  • Documents
  • Wiki Categories (repteated 30+ times)

I'm not sure if this "Term Set" setting even is involved, but the problem does seem to stem from an attempted and failed lookup into a term set somewhere.

Fwiw, I have looked this forum and per the commentary, did verify the settings are as expected.

So with that, does anybody have a suggestion on what I need to change to allow people to add in their own text into the "Ask Me About" without getting hassled about the term not being valid?

  • I'm also having this problem. Do you already have an solution? – Active_t Dec 9 '14 at 14:51
  • No, I did not. The problem persists. – Alan M Dec 10 '14 at 16:54
1

You should create a Term Set and select that Term Set in the "Pick a Term Set for this property" dropdown. Users are only allowed to pick terms from the term set you've set in the "Pick a Term Set for this property" dropdown. This term set could/should contain work related items e.g. "Excel", "Math", "Biology", "History" etc.

Working with managed metadat: https://www.webucator.com/tutorial/advanced-microsoft-sharepoint/working-with-managed-metadata.cfm

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.