1

I have an on-premises SharePoint 2016 server. The user Profile Service is set up to sync with Active Directory and all of my users have been pulled in. When a user goes to "About Me", they can click on the link to edit their profile, but can't actually change any information. I've checked the user properties pages for the fields I would like to edit and the "Allow users to edit values for this property" is selected. Is there something else I'm missing that would prevent users from editing these properties or is there possibly something wrong with my User Profile Service?

I'm not sure exactly what's going on with this although I'm sure it's related to other issues that I'm having with my User Profile Service. However, after going into the User Profile Service and editing a property there, it becomes available to edit for the user. Wish I had a way to rip this User Profile Service out and rebuild it, but when I tried that on my test site, it blew up My Sites and I can't afford for that to happen.

  • Maybe it's a browser issue, try to use Chrome or add the mysite URL in the compatibility view in IE. – Mohamed El-Qassas MVP Dec 17 '18 at 20:56
0

Can the user type the information in the text box when editing the profile?

Can you provide the screenshot about the issue?

And after editing the profile clicking the save button, the message will be prompted. It will take some time to take effect.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.