0

Hope someone here can help with an issue which is strange and new to me.

We have hybrid environment, running both SharePoint on-premises and Online. We have lot of services running in our organization. One of it is, employee directory where user has an option to change their profile picture. (This is the only place if they want to change any profile related information including profile picture). We have blocked users to change profile picture everywhere using exchange policies. Also, we have modified the default option for editing picture in SharePoint Online user profile service - "Picture" property and unchecked the option "Allow users to edit values for this property".

Now, as a result if they are going to skype for business, exchange or SharePoint they do not see option for change the profile picture.

Problem:

When user updated the profile picture in Employee Directory application, the profile picture will be updated in AAD. Once AAD has the latest image all service in O365 gets the updated image except SharePoint Online.

Is this because we unchecked the property of "Picture" in user profile service? As I understood, this option is just to disable the option for upload picture in Delve. But it is also not syncing picture from AAD.

Anyone has anything to say?

thanks in advance

-Praveen.

0

Pictures are never synchronized from Azure AD -> SPO via an auto-set property (users can use the profile settings in any O365/AAD service to update their own picture). This is because SPO uses AD Import which itself does not support setting pictures; the setting you changed doesn't do anything :-) A user profile photo picture sync should be triggered if the user goes to their Delve page, however.

  • I feel like you are wrong. This is not how the profile picture sync works in Office 365. If user has exchange online then the profile sync happens from AAD -> EXO -> SPO. If we did check the property for "Profile" attribute then it sync fine, if we uncheck it won't. Refer more information here: support.office.com/en-us/article/… – Rare Solutions Oct 23 '19 at 16:00
  • Again, there is no direct AAD -> SPO sync of profile pictures, as I stated. – Trevor Seward Oct 23 '19 at 16:27
  • So, here is the question I am trying to understand, as I stated in my problem: we have updated image in AAD, that is synced to exchange. If that is what synced to SPO then the latest image should be updated to SPO as well as exchange has the latest image. If that support article is true then it should get the latest image from exchange and it should be good. But, the tests we have done is showing "Picture" property is what causing this not syncing. – Rare Solutions Oct 23 '19 at 19:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.