0

I'm not able to create new Web Application, after do that the page in CA when I was creating Web App shows error that "Internet Explorer cannot displayed the websitebe" In IIS Site has a few less folders then normal Web App in CA I see new Web App but I not able to open General Settings I get:

Updates are currently disallowed on GET requests. To allow updates on a GET, set the 'AllowUnsafeUpdates' property on SPWeb.

In event log durring creating Web App I get:

Event 2303 There was an error during processing of the managed application service auto-start for application pool: 'SecurityTokenServiceApplicationPool'. Some application services may not have been processed correctly. Please check the configuration for application service auto-start for the application(s) assigned to this application pool. The data field contains the error code.

And I have noticed that from some time I get:

Event 8306 An exception occurred when trying to issue security token: The HTTP service located at http://"localhost":32843/SecurityTokenServiceApplication/securitytoken.svc is unavailable. This could be because the service is too busy or because no endpoint was found listening at the specified address. Please ensure that the address is correct and try accessing the service again later..

Event 2138 The SharePoint Health Analyzer detected a condition requiring your attention. The Security Token Service is not available. The Security Token Service is not issuing tokens. The service could be malfunctioning or in a bad state. Administrator should try to restart the Security Token Service on the boxes where it is not issuing tokens. If problem persists, further troubleshooting may be available in the KB article. For more information about this rule, see "http://go.microsoft.com/fwlink/?LinkID=160531".

I tried many things - restart server/service, reprovision SecurityToken and below instrucions but still I'm not able to create new correct Web Application.

The Security Token Service is unavailable

The Security Token Service is not available

Unable to create a new web application. Updates are currently disallowed on GET requests

Thanks for help.

  • Do you have many webapplications? Do it takes a long time to create the new one? – Christoffer Oct 27 '14 at 9:51
  • Yes I have a few Web Apps and it take long time to create it ... What can be a reson of my issue? I should add that I have a few SharePoint servers (2x WFE and 1x APP) and i use 2013 version. – Wilon Oct 27 '14 at 9:57
3

It sound's like the web applications get a timeout and does not get created correctly. I've had this problem in both production and staging environment, and changing the time-out has worked perfect both times.

This is usually because you either have too many Web Applications in your SharePoint Server, or because your SharePoint Server is slow! As part of the Web Application creation process, SharePoint resets IIS. By Default, the application pool only allows for 90 seconds for all the connections to close before it down by force. If you got this message it’s because 90 seconds wasn’t enough and we need to increase that limit.

I found the solution here, and it worked perfectly. Go into IIS and change the property "shutdown time limit" for the central admin application pool from 90 to 300 seconds. Now try to create your new web-application.

Internet Explorer cannot display the webpage when creating new Web Application in SharePoint 2013

  • It can be, I will do it now ... Is it enought to do it in App server or in all servers in the farm? – Wilon Oct 27 '14 at 10:09
  • 1
    The server where central admin is should be enough. – Christoffer Oct 27 '14 at 10:12
  • Thanks a lot, I was fighting with it since last friday - it works ... – Wilon Oct 27 '14 at 10:59
  • Glad to hear! :) – Christoffer Oct 27 '14 at 11:16
  • I have same problem and your tips save me! – Mark L Oct 26 '15 at 2:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.