0

I want variations to not update target pages automatically. So I run the following script on poweshell:

$rootWeb = Get-SPWeb http:///

$relationshipsList = $rootWeb.Lists["Relationships List"]

$propertyStore = $relationshipsList.RootFolder $propertyStore.Properties.Add("DisableAutomaticPropagation", "True") $propertyStore.Update();

But smth is not right. Because when:

1- When source is first published, I can manually click the button Create Varioation and than the target page is created. And this is ok

2- But when I republish this source page, the content updated is reflected to the target automatically.

I don't want the target page to update automatically with the minor version of the source page just republished. THIS was the reason I made it manual

Can I do this on Sharepoint 2013? How?

EDIT

Sharepoint 2013 has the variations settings page, but they seems they doesn't work

Do not recreate a new target page when the source page is republished, - I checked this but the page is still recreated

How to stop recreating the variation page?

  • What were your order of operations? Create page, run script, and then page gets pushed? If so, that could be the problem. Since variations run through timer jobs (at least in 2010), a job to push the page could be queued as those settings affect the queuing and not the actual push. – beavel Jan 5 '14 at 17:52
  • I did some test and I found out that after creating variations with automatic propagation it is way too difficult to change them. If you configure variation settings with automatic variations off BEFORE creating hierarchies it works. – MIlena Jan 6 '14 at 14:30
  • If that answers your question, I would recommend writing it up as an answer and marking this question answered to help anyone else having a similar issue. – beavel Jan 6 '14 at 15:40
  • This is an answer, but not the answer. It should be a way to set automatic propagation off, once you configure it as automatic. Because clients change their requirements and this way I need to recreate the site from the scratch?? – MIlena Jan 7 '14 at 8:11
  • I don't disagree that there should be a way to set this after the fact. Hopefully there is a patch that fixes this. – beavel Jan 7 '14 at 12:40
3

I did some test and I found out that after creating variations with automatic propagation it is way too difficult to change them. If you configure variation settings with automatic variations set ti off BEFORE creating hierarchies it works.

0

there is similar question on stackexchange please read it and something is missing in ur powershell command

[System.Reflection.Assembly]::LoadWithPartialName("Microsoft.SharePoint")
$site = new-object Microsoft.SharePoint.SPSite("http://yourserver/sites/abc")
$folder = $site.RootWeb.Lists["Relationships List"].RootFolder
$folder.Properties.Add("DisableAutomaticPropagation", "True")
$folder.Update();

Language Variations: Variation Page getting updated by source (When it shouldn't)

  • I'm sorry but I don't see smth missing?? Could you help me please? I already read the thread – MIlena Dec 27 '13 at 15:52
  • I run this script and the property is already added – MIlena Dec 27 '13 at 15:55
0

You can change the Page Update Behavior by going to 'Site settings' on your root site, clicking on 'Variation labels' (/_layouts/VariationLabels.aspx) and then clicking on your label you want to stop updating. There you can find an option called 'Page Update Behavior'.
The options are:

  • Automatic updates
  • Manual updates

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.