4

Title pretty much sums it up. Working on a doc template for a library, have a bunch of quick parts already inserted for various columns of the content type. If I add a multi-line text field, it will crash Word. I've tried to see if it's the "unlimited length" switch in the column settings, but that had no effect. I tried inserting any of these fields into a plain blank doc, and it crashes Word as well, so I don't think it's a cumulative effect of adding a lot of fields from SharePoint to the doc. Update - my multi-line field is set to plain text. Single-line entries work, but the character limit of 255 is too short for what i need.

Update from Microsoft.

Known Bug.

First reported to them around the 13th of September.

Exists in Office post v 7101.

KB2817537 and/or kb2817579 appear to have something to do with.

Per Microsoft, no fix until Office cumulative update in mid December (round the 13th or 15th).

Problem can manifest itself the way I see (full crash when attempting to insert the quick part). Also, in preexisting templates, the created doc may just not save.

No documentation of bug/issue exist on Microsoft's site yet because it's so new.

That's all I have. I will be looking at breaking my multiline into a string of single-line entries to get around the problem for now. Reverting Office versions would be an unworkable solution here.

  • Same Issue here. Word crashes when inserting a multi-line text field from SharePoint(Even when i add the Multiple-line Comment field from Word). I´m working with SharePoint 2013 and Word 2010. It happened after the September updates. There are already multi-line Quickparts in our invoice-templates and Word doesn´t save them anymore when there is a CR/LF in the quickpart. In Developer mode i can see that CR is allowed, but Word won´t save the file. This is urgent for us, because all invoices are made with SharePoint. It worked for years(WSS 3.0, SP 2010, SP 2013), now it broke. I also tried to – user19695 Sep 23 '13 at 9:11
1

If I remember correctly, the multi-line isn't compatible with much of anything outside of SharePoint. Try changing it to a single line of text and increase the char count and see if that works.

If you need to use multi-line, try it as plain text, but I have my doubts it'll work. Let me know if you find a work around, would be worth knowing.

  • Single line works...but since char limit is 255, it won't fit the same need as the multi-line. And my multi-line is set to plain text already... so no luck. – Carp Sep 20 '13 at 14:30
  • If i can't get a fix, I may try to do some sort of grab of string from the multi line... 255 characters at a time, assign them to some single line fields, and then stack the single line fields into the word doc – Carp Sep 20 '13 at 18:27
  • Maybe save the multi line text into a string variable in a workflow, then out put that variable. I created the email system in a workflow that would check various settings then if the condition was true, it would append it to a variable I called body so body = body + field, then at the end of the work flow I generated the email and plugged in my variable into the body of the email. – Oddity Sep 20 '13 at 18:31
  • trick for me (non-programmer) is what do i dump that variable into to get it into the word doc via the quick parts / document properties? – Carp Sep 20 '13 at 19:08
  • Hey, I found an article that may help, this guy was having similar issues as you and used some workflow contexts and metadata to achieve his goal. Might aid you as well. – Oddity Sep 20 '13 at 19:31
1

We had the same problem. Word crash on inserting the "comments" quickpart into a blank document. And no being able to save document with multi line quickparts already being present due to the text being in the "wrong" format. (not allowing newlines)

We removed two updates.

  • KB2760769. Removing this one fixed the crashing word issue on inserting the comments quickpart.

  • KB2760758. This patch did something strange in InfoPath. InfoPath generates the document information panel, in the panel a wrong validation regex was generated for the validation of mutliline fields.

Working version of office: 14.0.6129.5000, bugged version: 14.0.7106.5001.

Be aware the other (future) updates may bump the version of office. Watch for this file: MSO.dll.

More here: http://social.msdn.microsoft.com/Forums/sharepoint/en-US/415bb92d-5fb7-46cf-9235-d894036743c6/microsoft-office-update-kb2760758-breaks-multiline-text-properties-field-in-custom-content-type

0

Hotfix has been released, tested on a number of machines with good results.

http://support.microsoft.com/kb/2878228/en-us

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.